Audacity will not record when using Focusrite solo

Hoping someone can help because this is becoming frustrating. I was using audacity on my laptop with windows 10 with my focusrife solo plugged in USB. Recording voice audio with AKG perception mic. Had no issue when I first downloaded the previous version of Audacity and used it for the first 2 times. Was using Spreaker recording studio to record for a while, but recently went back to use Audacity because of versatility. First time I went to use I got the dreaded ‘error opening sound device. Try changing the audio host, recording device and project sample rate’ message. I simply unplugged the focusrite and plugged it back into a different USB port and everything was working fine for 2 weeks. Now I have the message again. I have tried everything on the help topic, everything on the forum and nothing corrects the error message. Audacity will record if I do not have it setup for my focusrite and use my laptop’s internal mic. Focusrite audio works fine if I open up Spreaker to record. So far I have :
-downloaded latest version of Audacity 2.1.3
-set my project rate to diff hz (always used 44100 before)
-made sure sound activated recording was off
-made sure overdub is off
-rescanned audio devices
-went into control panel and made sure audio devices were enabled, even had show disabled devices option and enabled that too
-made sure software play through is off
-made sure playback and recording devices correctly selected
-selected windows direct device as host
-made sure available inputs are in the windows control panel
-tried 44.1, 44.8, 88.2, 96 hz which is what the focusrite supports

Can someone please help!!

Try setting Audacity back to its factory defaults:

  1. Ensure that Audacity is not running.
  2. Go to "*Users<username>\AppData\Roaming\Audacity* " and delete the file “audacity.cfg”.

Reset the USB audio device by shutting down your computer completely, and rebooting.

Go into the Windows Sound Control Panel and check the recording settings for the Focusrite, and check that you see the green meters responding to audio input. Then set the Focusrite as the “default recording device”.

Launch Audacity and try to record something. With the above steps, the default settings ‘should’ be correct.

Note that if you are running AVG anti-virus, it blocks the Focusrite driver on Win10. Updating the AV solution and/or the Focusrite driver should do the trick…

It’s the heuristic scanner being a little over-zealous and producing a false positive. Seems to happen a lot with audio code.

On Windows 10 by default that means hold Shift and click on “Shut Down”.