Audacity Will Not Record A Song From youtube

When I click record in Audacity, it records silence instead of the song I am trying to download from youtube.
In the past I have always been able to start the record, then start the song on youtube and it shows the song being recorded.

I used an older version 2.3 for years and had no problem.
Downloaded 3.3 and now I cannot record a song… at first when I clicked “record” I would immediately get an error 9999… but I accidently got it to start the recording process, but it will not show the song I am playing.
I don’t know if this is related…I also recently began recording a radio show using a Peavey mixer and mike.
Could this be part of the problem.

I am computer-challenged, so please keep it as simple as possible… don’t assume I am very smart with computers and Audacity… for years I have used Audacity to process and normalize my music files… but it was just load the song up, edit the beginning and the end so they would have a second of silence on them, so they would play well without a lot of dead space on my CDs I made.

Would appreciate any help you might give.

These instructions have been updated for 3.3: Tutorial - Recording Computer Playback on Windows - Audacity Manual

1 Like

Just so you know, I have read all the previous posts related to my problem and tried to do the suggestions, but none of them worked.
Appreciate the reply, but reading the manual doesn’t give me an answer to my problem.

I don’t think youtube is restricting the recording. I have done this for many years with not problem.

I tried several recommendations… tried turning off the software playthrough… tried starting the song on youtube first and then hitting record… still will not record the song, but you can see the bar in the record track moving and indicating it is record… Audacity is not receiving the audio feed.

I turned off the sound activation mode.

I have checked my Audio Setup in Audacity and it has the settings that have always worked.

Could it be that my computer does not have the proper devices activated?

My Audio Setup in Audacity:
Host: Windows Wasabi
Playback Device: Realtek HD Audio 2nd Playback
Recording Device: Stereo Mix
Recording Channels: 2 (Stereo) Recording Channels
Quality: 48000 HZ

HP PC… 2 years old… pretty high quality computer.

A friend of mine is a computer tech… he spent two hours trying to resolve the problem… so I think the devices are enabled to play audio… I can playback audio from youtube… I can play music files through Media Player on my PC… Audacity records, but there is nothing being fed to it to record.

Hope this help.

Since you are only recording, you don’t need Software Playthrough or Overdub on.

As Stereo Mix doesn’t seem to be working for you, try WASAPI LOOPBACK recording as in the manual link. So set your Host to WASAPI and your Recording Device to “Speakers (loopback)”. You don’t need to worry about your playback device as Audacity will be recording and NOT playing.

Thank you so much jademan… it worked.

Thanks for helping a computer illiterate… appreciate you patience with my computer ignorance.

One more request… how do you upload a screenshot.

Do I just use the symbol on the taskbar marked “Upload”?

I know how to post screenshots on a baseball forum… hope it is similar here.

That would be the one - the upward arrow right between the quotes and the happy face. :grinning:

1 Like

Just want to thank this Community.

I have watched several hundred youtube videos trying to solve this record problem.

One post here and the problem is solved.

I’m glad I was able to help. :grinning:

1 Like

I’m having a similar problem, but with my Mac Mini (3 GHz 6-Core Intel Core i5, 32 GB 2400 MHz DDR4, Ventura 13.1). My interface is a MOTU 828x and ever since I got it I’ve been unable to record any computer audio into Audacity. The Audacity audio i/o are set to the 828x, but only silence gets recorded regardless of DAW or any other audio app including iTunes. I then downgraded Audacity from 3.2 back to 3.1 (don’t have any need for the plug-ins, and the constant prompts were annoying), but that hasn’t solved this issue. My older interface was a Yamaha MG12XU mixer w/USB, which Audacity never failed to record audio.
All input is appreciated!

Recording computer playback from an Apple computer is a totally different issue as Apple does not allow you to do this easily. There is third-party software availble.

But since you have a Moto 828x, you probably also have tons of 1/4 cables lying around. I haven’t looked at the manual but I am thinking you can simply jumper channels 1 and 2 outputs back to 1 and 2 inputs.

If you need to hear what is playing at the same time, you will need “y” cables.

This topic was automatically closed after 30 days. New replies are no longer allowed.