Audacity will not launch in El Capitan [SOLVED]

I downloaded version 2.1.1, and followed the instructions for installation (copied folder to Applications, etc.) Now when I double-click the Audacity icon, I get this error, and it fails to launch:

The application “Audacity” can’t be opened.

I see this in the Console:

10/26/15 8:56:19.078 AM Finder[17541]: spawn_via_launchd() failed, errno=111 label=[0x0-0x4d74d7].net.sourceforge.audacity path=/Applications/Audacity/ flags=1 : LaunchApplicationClient.cp #963 LaunchApplicationWithSpawnViaLaunchD()

I tried disabling Gatekeeper, but that didn’t help. I also tried deleting the ~/Library/Application Support/audacity folder, and even tried running directly. Finally, I tried this fix

Nothing worked.

Trash the Audacity you have, then delete Audacity from your browser download cache or download manager.

Then download 2.1.1 from us:

If the problem persists, please post an image of the message that says Audacity cannot be opened. To take the screenshot, COMMAND + SHIFT + 4, then SPACE, then click the error box. The saved PNG file is on your Desktop.

Please see here for how to attach files:


Updating to El Capitan 10.11.1 fixed it. Thanks.