Audacity vs Zoom H4nPro recording issue

Hello. Audacity 2.4.1. Windows 10.
I am trying to use my Zoom H4nPro digital recorder as a USB microphone interface.

Every time I click the record button, two red triangles appear and everything stops! Can’t record. I’ve done everything right, I think. Checked overdub, unchecked software playthrough, unchecked pinned, etc. Audacity recognizes the H4 mic and headphones. I’ve made sure that the frequencies match (44.1 0r 4800-doesn’t seem to matter which, although my computer default is 4800 for some reason). It works fine when I use the built in mic on my laptop (Dell XPS 15).

The Zoom has better mics, though, so I would like to be able to use them. This seems to be a recent problem, as I have been successful in the past. So, what has happened? Is this fixable? I might add that everything works as it should when I use my old Windows XP desktop system with Audacity 2.1.1.

Please advise.
Thank you
Bk in BWA

Are you using “MME” as the “host” in the Device Toolbar?
If not, try that.


I don’t have a H4N for testing, but as a workaround you could record on a flash card and then use a USB flash card reader to transfer the recording to your computer. That has the added advantage of avoiding computer fan noise.

record on a flash card and then use a USB flash card reader

Zooms also allow you to mount the internal card via a USB cable and transfer that way.

There’s good reasons to avoid computers during recording. An impressive number of forum posts would vanish without that computer. “What’s that ticking sound in my voice?” “Why is there a whiny sound in the background?” “How do I get rid of the computer fan noise?” “My computer can’t find my microphone!” “Why is my voice gargly and honky?”


Your point is well taken, kozikowski. It’s just frustrating for me because I have been able to do this in the past. My laptop is pretty quiet, so that hasn’t been a serious issue. My old desktop fan is very loud, so I don’t use it for direct recording. From other postings on this forum, I’m beginning to think that it’s just no longer possible to do what I want with Audacity. Oh well…I just downloaded a trial version of Adobe Audition. I’ll see if that works any better. Thank you for your responses.

A note because I’m just waking up. When I plug my H1n in, there is a screen asking me if I want to use it as a microphone or mount the memory chip. Do you get such a screen?

I just downloaded a trial version of Adobe Audition.

Or more likely, a trial version for a subscription to an Adobe Audition Forever Account. Read the documentation carefully.


So, here’s what I did: When I plug the zoom in, it gives me the option of storage or input/output. Choose input/output. It then gives two frequency options: 441 or 4800. Choose 4800. This works! I don’t know why. My laptop sound default setting is 4800, so this might have something to do with it, although the Audacity tracks themselves say 441/16 bit, and the Zoom itself records at 441. I would previously just automatically choose 441. I don’t understand all this, but so far it seems to work.
I will not be signing up for Audition, by the way. Too expensive.
Thank you.

I will not be signing up for Audition

They’re capitalizing on being turned into a common verb.

“Photoshop this.”


I’m going to try and mount my Zoom later and see what happens.


Well, I’m a photography guy anyways, so they’ve already got their hooks in me, but for my modest musical needs Audacity works just fine. I’m curious to hear about your Zoom experience.
Thank you, Koz.

I’m curious to hear about your Zoom experience.

It’s not going to be Windows. I am curious what happens on a Mac. I’ve produced technically perfect (enough) sound files, but I did it stand-alone. Connection to a computer is just inviting problems. And yes, there’s nothing wrong with the Zoom microphones.

There was one Zoom-ish complaint. I don’t know if you got into this or not. The recorder arrives with no memory card, and it won’t work without it. So major promotion and publicity problem. It comes out of the box dead. They even supply batteries, and they used to supply a tiny memory card. Not any more.

I was very stern with Sweetwater sound. I said I didn’t care about the configuration, but I care a lot that nobody told me. Production doesn’t like surprises.

I live in LA, so a new memory card was about two miles away, but still.

As we go.


This is going to be little to no help, but on one Mac I tried, it connected well assuming I know the spells.

Mount Zoom H1n for Live Microphone

— Zoom —
Plug in USB cable
Power Up

Audio I/F <
Card Reader


Bus Power <

Meter bounces with Sound.

— Mac —
System Preferences
H Series Stereo Track Usb Audio
Bouncing Preferences Meter

— Audacity —
Audacity 2.4.1
Input Selector
H Series Stereo Track Usb Audio

Click in recording meters - [Start Monitoring] - Bouncing sound meters
Record a Performance
Export or Save the work.

— Zoom —
Option+Exit (firm)
Unmounts the memory chip (wait)

Unplug USB cable
Power off.

— Audacity —
Rescan Audio Devices

— END —

And there, in one long instruction list is the reason I can’t recommend the Zooms straight-away for casual recording. I know how it works and I had to go look up some of the steps.

And to bring this back around, I never had to struggle with sampling rates or bit depths.

I know about the bad edit at 20 seconds. I don’t stutter at convenient edit points.

I don’t know what that thing at one second is. I assume it’s an artifact of using a Zoom to record directly into the computer—which you should never do.


I bumped up to the same mysterious problem. The cursor just hanged and couldn’t record. The same happened in Win 10 and 11. It used to work, but most probably after a Win update it stopped working. But this workaround works! Great! Thank you!