Audacity Vinyl Recording Unusually - Snapping to Beat?

Hello. Apologies if this has been discussed already - I had a search and couldn’t see a similar issue, but hope it’s not a duplication.
I’ve used Audacity extensively in the past to record and edit DJ mixes, but my new project is recording all my old vinyl to digital.

This is all old 90’s hardcore / dance / rave.

Numark TTX1 turntable
RCA to XLR cable directly out of turntable into
Behringer UMC202HD interface
USB into Windows 10 laptop - Audacity

I have included a WAV from the original track, and a WAV from what Audacity is recording.

Original track:!Al-C4dylddrhhL5nQZT4eYWvWw9Y7Q?e=aVxp3J

My Audacity recording of track from vinyl:!Al-C4dylddrhhL5o3R5auu6FOLisXw?e=aVqDAF

I’ve also included a screenshot.

You can hear from the first clip it all sounds fine, but on my recording, Audacity seems to be performing some kind of weird snapping of the beat.

When I monitor this through the Behringer interface it sounds perfectly fine. This just seems to be something that Audacity is doing. I have changed any of the default settings except to change the Project Rate to 192000.

I thought it may have been some kind of latency with recording but it isn’t. Everything closed down, CPU barely being used, Latency Mon app shows everything to be fine.

Any suggestions as to why Audacity is recording like this would be greatly appreciated.

Audacity 3.1.2 being used

The problem is that there’s a bottleneck somewhere in your computer system and it can’t capture all of the data to disk in time, so parts of the sound are missing from the recording.

Here I have moved parts of the recording to line up with the original so that you can see where the parts have been dropped:

Does the problem happen with the default sample rate of 44100?

Thanks for taking the time to reply and for looking into the problem.

I just don’t think it’s buffering / latency that’s causing this. It’s the same even if I drop the sample rate right down. However if that was the case, wouldn’t the recording drops be more sporadic? The gaps are at the EXACT same intervals (end of each bar) and and snapping the next bar? That behaviour is consistent every single time I record this intro. Surely just data capture latency would behave in a more random fashion than that?!Al-C4dylddrhhL5pk26BctUuQ7GbkQ?e=nMbGpu

The laptop spec is high, and all other programmes and processes are shut down. I did think at first it may be just recording lag, but this isn’t present in any other music software I use.

Just seems like there’s something simple here that’s causing this!

I just don’t think it’s buffering / latency that’s causing this.

Dropouts and glitches are USUALLY buffer-related although increasing the buffer doesn’t always solve the problem.

A buffer (which is also a delay) is required because of the multitasking operating system. The operating system is always multitasking even if you’re only running one application. When you record digital audio data flows into a buffer at a smooth constant rate. The the operating system gets-around to it the data is read from the buffer and written to the hard disc in a quick burst. If the buffer doesn’t get read in time, you get buffer overflow and a glitch.

CPU barely being used

It’s not the total CPU time… Some application/process/driver just has to “hog” the system for a few milliseconds too long and the if buffer doesn’t get read in time you get buffer overflow… A faster system often helps because the other processes run faster.

192kHz is more than 4 times as much data as 44.1kHz which makes the buffer fill-up (and possibly overflow) faster. “CD quality” (16-bit, 44.1kHz) is better than human hearing and obviously better than vinyl. (The resolution of vinyl is limited by noise.) And you might be able to record without glitches which would be better!

Okay I’ve found the problem, so posting here for reference.

‘Sound Activated Recording’ was enabled. This needs to be disabled. The definition makes perfect sense:

Sound Activated Recording: Enables or disables Sound Activated Recording. When enabled, click the Record button in Transport Toolbar to start the Sound Activated Recording session. … Recording will pause whenever the received input falls below that level.

Therefore, at the end of each bar after there was a sound gap, it was ‘closing that gap’ which makes sense as to why it was routinely after each bar in the intro but not when the song had started fully.

I was able to find this out by getting an old laptop (much lower spec), installing Audacity from scratch, trying the recording at 192000 and noticing it worked perfectly. Then just a case of comparing recording settings in preferences.

Thanks to the contributors to this thread for taking the time to provide some advice.