Audacity UI blurry in Windows 10

Hi Folks,

I just installed Audacity on Windows 10. I’m using the most current version of Audacity (2.3) loaded on to a freshly updated Windows 10. Oddly, the user interface for audacity seems blurry. That is, it almost looks a little out of focus, as if the screen resolution of the audacity window doesn’t quite match the resolution of the monitor. Any idea what’s going on?


Windows 10 has more settings for “dpi scaling” (dots per inch) than previous versions of Windows. These settings are for optimising the appearance of applications when using a high dpi display. Try tweaking those settings for the best appearance.

Thanks for the suggestion! I tried all of the DPI control settings in the application’s properties with no improvement. All of my other programs, including Libre Office and TurboCAD look fine.

Hi Rob,

I had this same problem last fall (so much so that I used Audacity on an old computer where it was still installed rather than continue looking at the blurry UI).

Earlier today I installed a new version of Quicken. After having the same blurry UI issue with it, I searched for some possible fixes. I finally found one that worked with Quicken, so I gave it a try with Audacity.

  1. Close Audacity.
  2. Right-click on the Audacity shortcut. Choose Properties, then go to the Compatibility tab.
  3. Click ‘Change high DPI settings.’
  4. Check ‘Use this setting to fix scaling problems for this program instead of the one in Settings.’
  5. Check ‘Override high DPI scaling behavior. Scaling performed by: Application.’
  6. Click OK. Apply the changes and restart Audacity.

I’m not sure if you tried this previously or if any recent Windows updates tweaked the DPI settings, but this seemed to work for me (it at least looks better to my 40-something-year-old eyes than the UI originally did).

New laptop (Lenovo ideapad S145) came w/windows 10 and just installed Audacity. Blurry screen. I tried the previous suggestions but no Compatibility tab is available. This solution worked for me: Get out of the Audacity program, right click on the main screen of your computer, tap on Display settings, the automatic scaling setting is already set, go down to Advanced scaling settings, under Custom Scaling Size re-enter the same size that was previously set on automatic, tap Apply, sign out of your computer, sign back in and go back into Audacity. The script will be smaller but very clear. You can try different scale sizes to try to get the perfect scale for you. Hope this works for you.

Here are the compatibility settings that work best for me on a 4K monitor. Apply these to a short cut rather than the executable file:-
Go to properties - compatibility - change high dpi settings
tick override high dpi scaling behaviour
choose system (enhanced) from the drop down options. ( In my case if application was chosen screen geometry overlapped badly).

You can apply different values to different shortcuts for comparison but only one instance of audacity can be running so you can’t compare side by side.

The mthod you suggest may work, but it is shrinking the UI ellements and it’s realy hard to work with. Does anyone have any other sollutions to the problem.

Oh my, thank you for this! It actually worked!

thanks, worked. though now, everyting is smaller…i guess i have to choose…

I just downloaded Audacity on my Microsoft Surface laptop.
And boy, I cannot believe this blurry mess that came up. This usually happens when I run programmes that were made for Windows XP and has not been updated for 20 years.

What is happening? This programme has an auto-update feature so I assume it’s not dead. Why isn’t it being optimised for the most used operating system on the planet, running higher resolutions than 800 x 600?

Edit just so everyone can see the blurry mess: