Audacity takes very long to start

I have recently installed Audacity 2.3.3 and have been using 2.3.2 before for quite some time without problems. My OS is Windows 10, most recent version, 64 Bit.
I am currently experiencing a very long start time of Audacity (about 15+ seconds) and I cannot relate this to anything I have done lately. The log shows me this:
19:29:00: Audacity 2.3.3
19:29:00: Error: Couldn’t find symbol ‘AudacityModule’ in a dynamic library (error 127: Die angegebene Prozedur wurde nicht gefunden.)
19:29:13: Trying to load FFmpeg libraries…

To me it looks as if the error mentioned in line two is causing this delay. Unfortunately the error message does not tell me what I can do to get rid of it. Any advice you would have for me?

Thanks Alfred

Did you install both the 2.3.2 version, and the 2.3.3 version using the Audacity installer (The “EXE” version rather than the “.ZIP” version)?
Did you install either of them to a custom location?

Hi Steve,
yes I have installed both versions from an .exe installer. I have de-installed 2.3.2 before I have installed 2.3.3 and I have (as far as I remember) not used a customer specific install location. I am certain about this for 2.3.3. The 2.3.2 install was quite some time ago, so there is some uncertainty, but I am pretty sure I have not selected another location then.



Please don’t double-post. To prevent spam, there is a delay until a moderator reads & approves your posts. After several legitimate posts you’ll be “cleared” and your posts will show-up immediately.

Sorry for being impatient - won’t happen again.

Quit and relaunch Audacity, then go to:
“Help menu > Diagnostics > Show Log”
Save the log somewhere convenient, and attach the log file to your reply.

Here is the log.
audacity_log_2020_03_12.txt (3.49 KB)


Has your computer been rebooted since you upgraded from Audacity 2.3.2? (I know you said it was some time ago that you updated, but some users reboot their computers very rarely).

Yes, it has certainly been shut down and restarted many times since installing 2.3.3.

I’ve seen a couple of other reports of this error message, but I don’t know how to reproduce it.
I’ve written to the developer’s mailing list to see if the developers can cast any light on it. I’ll post back here if I get any useful information.

Ok Steve, thanks for your efforts.I will keep trying things and post my findings here.

I have noticed this morning that I have 2.3.2 installed on my Laptop and getting the same error message there: Error: Couldn’t find symbol ‘AudacityModule’ in a dynamic library (error 127: the difference being that Audacity starts on my Laptop in 2 seconds where it needs 20 seconds on my main machine (which is significantly more powerful). Installing 2.3.2 after deinstalling 2.3.3 doesn’t change anything on my main machine (still getting a startup delay of about 20 seconds). At the time being I am not convinced that the error message is in an way related to my startup problems or to the 2.3.3 version.

Not sure really, what to try next. Is there any instruction available how to conduct a clean deinstall of Audacity?

That’s pretty easy because Audacity only puts files in two places, and uses configuration files rather than the Windows registry for settings.
The program files are in \Program Files (x86)\Audacity. These are removed by a normal “uninstall”.
The configuration files and other bits are in \Users__\AppData\Roaming\audacity (where is your log-in name).

To reset Audacity to factory default settings, close Audacity, then open the hidden folder:
and delete the three files:

Those three files will be recreated with factory default settings when you restart Audacity.

I was going to suggest resetting Audacity to see if that has an effect on the problem of the slow start up.

I have tried a clean install - but no change.

A suggestion from one of the developers…

Look in
*\Program Files (x86)\Audacity\modules*
What files, if any, are in there?

In “modules” I can only find “mod-script-pipe.dll” - as you’d probably expect after a clean install.

Yes, that is expected.

If you move “mod-script-pipe.dll” out of the Modules directory, do you still see the error and the slow start-up?

No, the error is gone - Yes the startup delay remains the same.

Does your machine have a drive or HDD light where you can see it? When you start Audacity does it go nuts (flash madly) for the whole startup time?


Are you using Network Connected Drives, Cloud Drives or G-Drives? Does it still do that if you disconnect your internet, restart the machine and then launch Audacity?


Yes I can see the disk LED but it does not flash more often when I start Audacity compared to the moment just before this happens. When starting one of my other audio editors e.g. SpectralayersPro it flashes significanlty more often compared to when starting Audacity.