Audacity stops recording at specific point

I’ve tried multiple times with the same cassette and each time this occurs.
Using Windows 7, Audacity version 2.1.2, inputting sound from a cassette with a Scarlett 2i2 USB connection. I’ve used Audacity in the past without trouble, but now the recording suddenly stops at 9:16 for this particular cassette. I don’t know if another cassette has a similar problem.
Any ideas?

Look at the bottom of the Audacity window and make sure Snap To has not been tuned on.

Also Transport > Timer Record has not been set.


Negative to both - snap to is set to Off and Timed Recording has not been set.

I tested it with another cassette and experienced the same problem. Never stops at the same time, although it usually lasts for less than 15 min.

It is a new phenomenon - did not occur in the past.

Are you running out of hard drive space? If you’ve been using this software and Win7 for a long time, you could have just run out of space to put new work.

This is a common problem with the video people. “I’ve been doing production for a long time and today, suddenly, for no reason, it just stopped working.”


Connect the USB cable tightly at both ends and shut down the computer. You cannot record from USB devices indefinitely without rebooting.


No, it’s a brand new computer with 500GB of hard drive space.

I tried recording the cassette into Audacity on another computer, that one is version 2.1.0, and had no trouble at all - the program did not stop at all. Could it be a bug with the current version?

Try reading this post above


So if I reboot the computer it should start working again?
That sounds odd.

It’s not odd at all, or we would not suggest it.


Please post in your topic if you want help. We don’t help anyone by private message.

The best recommendation remains to ensure the USB cable is tight at both ends, or try another cable.

Yes you can use any recording application if you think that will help - you are not tied to using Audacity.

If the other application records consistently, it probably means your settings are wrong in Audacity. For example, “Audio to buffer” in Recording Preferences is too low, Project Rate bottom left of Audacity is in excess of 44100 or 48000 Hz, or Audio Host in Device Toolbar needs changing.

When you choose your Project Rate in Audacity, you may need to open Windows Sound and make sure Default Format for Scarlett recording is at the same rate.

If you don’t need to listen in the computer while recording, turning off Transport > Software Playthrough might help too.


I gave up trying to fix this issue. The suggestions posted here have all be tried, but to no avail. I don’t know why Audacity suddenly stops recording and freezes only on this computer, but sadly that is the case. :frowning:

My workaround is as follows - I record the sound into my computer using RecordPad Sound Recorder, which is a free, lightweight sound recording program for Windows.
Then I import the file into Audacity as a project, edit the sound as needed, and export again in the final format I wish to save.
Sorry this doesn’t have a happy ending, but at least I can get my work done.

Thanks for letting us know. Perhaps “lightweight” has something to do with it. RecordPad records in one stream direct to the target format rather than writing temporary files every few seconds. Perhaps there is some disk I/O or USB bottleneck that can’t cope with what Audacity does.

If that guess was correct you might be able to solve it by creating a shortcut to launch Audacity and setting a much larger blocksize as an argument in the shortcut, so that Audacity did not write so many small files.