Audacity stopped detecting mic input

OS: Ubuntu 20.04
Audacity: 2.4.2 (installed through Ubuntu Software Centre)

These are my current versions, but this is a problem that started in 2.3.3. Also I recently upgraded Ubuntu and while I can’t remember when exactly I upgraded in relation to this audacity problem. But I’m quite sure that the problem didn’t start right after upgrading (either it existed before the upgrade or it started a little while after).

I have been digitizing vinyl and cassettes but running an aux cord (1/8") from the headphone jack on my amp into the mic jack on my computer. Everything was going fine, I did it with a few dozen albums, got into a rhythm. Suddenly it just stopped. No input was detected. I seemed to have a whole bunch of different options under the input option (clicking on the microphone drop down menu on the toolbar). Nothing with any of them. I upgraded to 2.4.2. Same problem. Tried all the options in the drop down menu (there was ~25) still nothing. I know it’s Audacity because my computer still detects the input just fine (in Settings > Sound > Input, Input device is “Rear Microphone - Built-in Audio”, shows the signal coming in).

Now, all the options from the drop down menu have disappeared (I believe that happened when I reinstalled 2.4.2 again). So on the Device toolbar I now have: “ALSA”, Mic:“default”, “2 (Stereo) Recording Channels”, speaker: “default”. Only the number of channels drop down has any other options.

Also (and I believe this is also new since all the other drop down options disappeared, but I’m not 100% sure) the input is my computers output. It used to be that I could be playing sound on my computer while recording. I have also tried plugging a mic into the jack and couldn’t get input from that either.

I don’t know if this is anything (it happens with other programs too), but in the software centre when I go to Audacity I got a notification ‘Sorry, something went wrong: Error opening directory “/usr/share/appdata”: No such file or directory’.

I don’t know what to try at this point. Any help is much appreciated.

That’s probably a Snap or Flatpak version. We’ve had multiple reports of problems with those. Go back to the deb version (Audacity 2.3.3-1build1)

Thanks for the reply, I’ll try that! Where can I find that .deb file?
(Forgive me, I promise I looked before asking)

It should be available in the Ubuntu Software Centre. Look for “Audacity 2.3.3”.
(uninstall Audacity 2.4.2 first)

Sorted! Nothing in the software centre but I tried installing


via terminal and audacity_2.3.3-1build1_amd64.deb from via software centre. Reinstalled the 2nd way because I thought the problem was persisting. Then I noticed my input drop-down options were back and one of those worked. Don’t know what happened but I’m back where I wanted to be. Thanks!