Audacity running on 3 machines none of them work, plz help

I have the sound program audacity running on a PC windows 10, a Mac book pro, and a Chromebook and none of them will work. This will be my third audio book I am narrating, and I am running into problem after problem this time. Upon the latest update 3.5 on the PC the program started producing MP3 files that are corrupt and ACX rejects them due to this, I get a message that they are automatically deleted from my one drive because they are corrupt, if I try to restore them I can but they are corrupt and rejected by ACX. This is my biggest problem as I would like to be able to use this computer for this purpose. I tried to download the previous version, but this didn’t fix my problem. I tried to uninstall and reinstall, did not fix my problem. I tried all the YouTube fixes, and I am on the Audacity forum, but nothing works.

So, I downloaded a Linux version to a Chromebook, but it will not recognize my USB mic, I tried all the YouTube fixes. Nothing works.

So, I downloaded the Mac version onto a friends Mac Book pro, I ordered the USB adapter but tried to use a Bluetooth mic until then and it sees the mic and it is listed on the recording source option menu but when I select it no sound comes out of the mic.

If someone could help me with any one of these issues, I would greatly appreciate it as I have a contractual deadline looming. Please and THANK YOU!

Did you grant access to the microphone in the system settings?

BTW more than one single thread for the same subject is not welcome in most furums.

Yes I did. I tried all the youtube fixes.