Audacity records in-game sounds instead of microphone

Hi there, I hope I didn’t duplicate any existing topic.

I’m planning to do a Let’s Play video (playing video game + live commentary) and I heard that the best combination is Fraps(or other video capturing software) + Audacity, to record audio.
I have a great problem with Audacity I tried to solve so many times, but without any effect. The thing is, that when I press ‘record’, it records my microphone and everything’s fine. But when I launch the game, it records the in-game sound that is so load that my voice cannot be heard.

I though it might be because game sound is so loud - but for recording in-game sounds I have Fraps, Audacity should record ONLY my microphone. And I’m using headphones, so it’s impossible for speakers to interrupt.

Please help. Thanks.

Use Fraps to record both the mic and the in-game sound. You will probably need to turn down the volume of the in-game sound so that your mic can be heard.

How do I do it? I’ve never seen such option on Fraps.

Google is your friend:

Ok thanks.

Another problem is - how do I disable internal sound in Audacity? I googled that by there was only questions on how to turn it on - but I want to disable it.
I was able to have it disabled during recording using Avnex Virtual Audio Device - but I downloaded new drivers to my sound card and now it doesn’t work.

I’m not sure what that means.
Do you want to record only your microphone and not other sounds that are playing on your computer? If so, then set the recording input in the Device Toolbar to record from your microphone and not from “Stereo Mix” or “Microsoft Sound Mapper”.

Has anyone figured out how do I disable internal sound in Audacity?

Select the recording input and playback output devices that you want to use in the device toolbar.