Audacity recording session: a load of distortion all I get!

Linux version: KDE Mint 17.3 “Rosa”;
Audacity version: 2.1.2, installed from safe PPA;
Lenovo laptop Dual core AMD E-300 APU 32 bits;
3 USB ports (1x 3.0; 2x 2.0);
no line/mic input.

USB Audio interfaces:

Zoom R16 audio interface functionality;
Behringer Guitar Link UCG102 (in conjunction with qjackctl).

Hello all,

For longer than I care to remember I haven’t had a fun recording session. Every attempt forever and anon culminating in sorting out IT. And for hours on end. Getting decent sound out of an electric guitar not going to work today either, by the looks of it. Whatever I try.

I tried to make a screenshot of what Audacity looks like on my screen, but that didn’t really work out. But of this bit I tried every combination possible:
In drop-down menu (‘default’) in-between ‘ALSA’ and ‘Mono’:

  • HD Audio Generic CX20590 Analog (hw 0.0)
  • sysdefault
  • pulse
  • default

In ‘default’, to the right of ‘Mono’: all of the above, plus ‘front’, ‘Surround40/51/71’,and dmix.

Whatever the type of audio interface and whatever the combination of options offered, all I’m hearing is massive distortion (Zoom R16). Or otherwise Audacity just freezes stone dead, or simply crashes (Behringer Guitar Link): especially if ‘front’, ‘Surround40/51/71’, and dmix are involved.

In the meanwhile, this is Audacity’s mic/line Input (I think). I can’t see any way of reducing input level: sliders refusing to budge any which way.

Under my signature you’ll find a short impression, in MP3, of what I’m hearing, when strumming my guitar. Latency considerable, BTW,

If you can make any sense out of this, then I certainly hope to hear from you!

Veerstryngh Thynner

Sounds like you’re recording from the computer’s built-in mic, rather than a USB device.
If you tap the computer case whilst recording that should confirm you’re recording from the computer mic.

Trebor writes: > If you tap the computer case whilst recording that should confirm you’re recording from the computer mic.

Trebor, thank you for replying. However, fact of the matter remains, unfortunately, that I can’t record at all! Once again, I tried every possible combination of options as offered in the drop-down menus below:
In ‘default’ left of ‘Mono’:

  • HD Audio Generic CX20590 Analog (hw 0.0)
  • sysdefault
  • pulse
  • default

In ‘default’, to the right of ‘Mono’:

  • HD Audio Generic CX20590 Analog (hw 0.0)
  • sysdefault
  • front
  • Surround 40
  • Surround 51
  • Surround 71
  • pulse
  • dmix
  • default

Whatever the combination of configuration options attempted (36 in all), nothing ever works. Either Record and Stop buttons freeze dead so that the test recording has to be “killed”, or tracks become solid blue. Otherwise Audacity simply crashes. And with all of this comes screeching, scraping and clicking most horrendous. Only default & default function to some extent. That is to say: less distortion here than in the other 35 trials, yet still too much to record musical instruments with any success.

Where, in the test track, a fine dotted line should be, ideally - without any audio input implemented, that is - a thick band of “compressed” waveform shows instead:
And this is where the audio input regulator comes in:
The only manner to decrease this distortion, as I see it, is to move its audio input slider button (now positioned at the far right of the scale [= max]) to the left. In playback output (to the right of audio input, as signified by a speaker icon) this is easily done. The audio input slider, however, refuses to budge. In all test runs throughout, it remains stolidly greyed-out. Whatever the configuration set-up. I experience this on my desktop, too - which runs KDE Mint 17.1 “Qiana”. Different configuration options, but the issue the same. Here, Audacity has also been upgraded, since recently, to 2.1.2 (from 2.0.5).

How exactly do you (re-) activate that blasted audio input slider? Once again, I spent two whole days trying to sort out this kind of IT shit. And once again I’m getting nowhere!

All I want for Christmas is a return to music production proper (i.e. without this endless IT hassle). So please please please: any helpful suggestions for some workaround, out there?

Veerstryngh Thynner

Yours is a Linux problem, not an Audacity problem. I think the solution lies in QJackCtl

Trebor writes: > Yours is a Linux problem, not an Audacity problem.

Could you elaborate a bit more on that please?

Furthermore, if no solution is to be got from the Audacity Forum, where to go next? It’s either that, or forgetting wholesale about recording in Audacity.

If that damn audio input button can’t be moved any which way, then Audacity may well follow the way of predecessors LMMS and Ardour (both not my cup of tea, really) - again, at least as far as Audacity’s recording facilities are concerned.

But the link you included may well be useful. Thank you very much for that.

Veerstryngh Thynner

Audacity, nor any similar DAW, can’t record from devices which are not configured properly : they can’t record from devices they can’t “see”. Adjusting QJackCtl should enable Audacity to “see” your USB devices, only then you can record from them.

I never had this kind of problem with Audacity. Well, never before v. 2.1.2, anyway.

Qjackctl has been added on my laptop, of recently, but making Audacity recognise it is something completely different. Audacity’s configuration drop-down menus on the desktop, in the meanwhile, may contain links to jack. I’ll have to check on this, though.

In older Audacity incarnations, I went the “analogue” way: a vintage multitrack recorder as pre-amp much less hassle than with jack, in my experience. The more since I never really got the hang of jack configuration. Frankly, I’ve always found jack a little daunting, if not slightly intimidating, being of a generation to which computer skills don’t come naturally. The configuration bit especially.

I haven’t yet had occasion to try out the “analogue” approach, in Audacity 2.1.2, but I’m wondering now if that would still work.

Veerstryngh Thynner