Audacity recording blank

Hi, I’m recording using my Focusrite 2i2 audio interface and it doesn’t seem to record records a blank file.
I’ve recorded it many times before but there was no such problem. I started facing it recently then I tried reinstalling audacity and it was solved but now for three days I’m again facing the same problem. I’ve tried everything I knew and it doesn’t seem to solve the problem the audacity is ofc updated, and the recording inputs are correct I’ve tried uninstalling and reinstalling it three times already. Pleaseee help.
I’m attaching the image below

Two things to check:

  1. Transport > Rescan Audio Devices, then redo Audio Setup; make sure you are NOT recording from the loopback device.

  2. Right-click on the Speaker Icon in the Windows Taskbar, then select “Sounds”. In the Recording Tab, select your Device. If Windows doesn’t see anything coming in then neither will Audacity.

Hii, It’s selected as usb interface only but still can’t record.
And I don’t understand the first point can you please help me with it in more detail.
Thank you

So in Audacity, in the menu bar you will see a selection “Transport”. So click on that, then you see a sub-menu item “Rescan Audio Devices”. Click on that. Then you will see a big fat button at the top of the screen, “Audio Setup”. So click on that then explore the submenus to select your device.

If you hold down the Windows-key, the press the “R”-key, then type “mmsys.cfg”, then click on the “Recording” tab, you should be able to monitor audio from your interface.

You may also need to check your microphone permissions, but as you said you have done this before, you man not need to do this.

ohh, hiii
I clicked on rescan audio devices and nothing happens

when I click on rescan audio devices nothing happens and I don’t see any button like “Audio Setup”

Look again. It is the top center of the first picture you posted.

ohkk, thank u
I found it
I first clicked on rescan audio devices then on audio setup it was already selected on interface even earlier too and it still doesn’t record :frowning:

It was working absolutely fine I am recording on it for more than a year this problem came up recently last time I re installed audacity and it solved but now tried everything and I’m so confused what’s wrong

Sorry that I wasn’t able to help. :roll_eyes:

it’s ok
thank u anyways

and if u could do a lil favour,
please refer this thread to anyone you know would be able to help on this. thank u

This topic was automatically closed after 30 days. New replies are no longer allowed.