Audacity recording always captures audio from VLC

My setup:
-Linux: Lubuntu 18.04 64-bit
-Audacity: 2.2.1-1
-Installed from: Ubuntu distributions standard repositories

The issue I am facing is that whenever I try to record an audio track using Audacity, I notice that Audacity is capturing audio being played by VLC (3.0.1-3build1, also from Ubuntu distribution standard repo). What I am trying to do is to play a Karaoke MP4 file in VLC, with output being directed to my headphones (closed-back with extremely minimal sound-leak), while recording my voice using a large diaphragm condensor mic through my PC’s onboard (Intel HDA) soundcard (ALC877 codec). It is as-is audio-out is being monitored and being mixed with the mic audio-in being captured. As a result, I am not able to record a clean vocals track that has only my vocals (without the audio output of VLC being overdubbed on same track). What can I do to improve / fix my situation to get clean vocals track recorded ?


There is no need to use VLC. Audacity is a multi-track audio editor, so you can import the backing track into Audacity, and have it play while recording a new track.

Note that when using an on-board sound card, it is unlikely that you will be able to hear your own voice through the headphones while you record - if you can, then it will probably sound like an echo, and your newly recorded track will be a mix of your voice and the backing track.

There’s a bunch of tutorials about overdub recording in the manual:

Thanks Steve. Reason for using VLC is that these are karaoke videos (MP4 files, that also show the cues and lyrics). For those songs for which I very well know the lyrics, I just import the MP3 backing tracks in Audacity and overdub.

My inbuilt soundcard has a monitoring option, but I’ve already used Alsamixer to disable it. I have tried to manually select Audio device setting to use PulseAudio and use PulseAudio Jack bridge to route the audio streams through Jack (all check using QJackCtl), but I don’t seem to be able to get rid of the unexpected audio capture of any other application generating audio mixed into my vocal track in Audacity.

OK, Is see.
So is your plan:

  1. Record vocals in Audacity, using VLC for cues.
  2. Import the backing track into Audacity
  3. Synchronise the two tracks
  4. Mix and export.

If not, please describe what you are trying to do.

What is the sound card, and how do you set it for monitoring?

Are you using PulseAudio Volume Control (pavucontrol)? If so, what settings are you using? If not, how are you configuring where the audio signals are coming from and going to?

What are your settings in Audacity’s device toolbar?

Precisely, that is indeed what I plan do.

The sound-card is the onboard ‘Intel PRO HD’ one on MSI H310-PRO VH motherboard (specs:, based on Realtek® ALC887 Codec, and claims “8-Channel(7.1) HD Audio with Audio Boost”.

Later today once I reach home, I will share the screenshots of alsamixer and PavuControl (I have, and use both), but if I am not mistaken the monitoring is controlled by the alsamixer playback/recording option called “Loopback” that can only be enabled/disabled. Currently, I have it disabled. Will also share the Audacity’s device toolbar settings later today.