Audacity playback is too fast

I have been using audacity to record live streams not used for a while must of had an update because three things are different now I use it

one it waits for noise to start recording, not just start recording ?

two the recording plays back at a faster rate by default ?

three no stereo mix option (have to use wasapi?) I was api before

can turn recording down to 0.01 rate what’s this?, but why do this in first place is there an alternative programme u use I cant believe they have done this to the program unusable for me now .
I am using Windows 10 and Audacity 2.1.2

When recording with WASAPI loopback, there needs to be an active audio stream for Audacity to record. It does not need to be noise, it can be pure silence, but it has to be an active data stream. That’s how Microsoft designed WASAPI. Generally that is a good (useful) think because it makes it very easy to start the recording from exactly the point at which there is something to record, so it saves having lead-in silence that has to be cut off later.

There’s a mismatch in your sample rate settings somewhere. Check that the Audacity “project rate” (lower left corner of the main window) matches with the record and play setting in the Windows Sound Control Panel and the settings (if any) in the application that you are recording.

That’s down to the sound card drivers. Some sound card drivers provide Stereo Mix, some don’t, some do but call it something different such as “What U Hear”.

The current version is 2.1.3, which is available here
Updating Audacity will not in itself fix this problem but there are other fixes and enhancements that make it a worthwhile update.

I was having this issue of too fast playback after I tried to record anything in addition to the tracks I had. I’m running 2.0.6 on Windows XP sp3. I had been using it with no problems for quite some time so some timing thing must have changed somewhere. I’m using a pci 5.1 audio card that had also seemed to be fine for a long time. The fix was that I reinstalled my sound card driver from a fresh download from their site. I hope this may help someone else with a similar problem.