Audacity picking up overdub on another track.


I’m recording a synth track from a plugin to a backing drum beat (overdubbing). The synth track is also picking up the drum beat during recording, though (so it sounds like there’s an echo). How to I prevent Audacity from picking that up?

How to I prevent Audacity from picking that up?

You don’t. In order to record your synth, you have to configure your computer to record its own playback. Recording its own playback is where the drum backing track is.

This is hard… Transfer your drum track over to your phone and play it to you with good quality headphones while you record your synth to Audacity in straight recording—not overdubbing. That should give you two separate tracks without the interaction.

It’s going to be wildly out of time/sync in Audacity, but that’s a snap to fix in post with the Time Shift Tool.

If you think about it, you can build lead-in ticks and repeat the ticks in the synth. [tick–tick–tick–tick] MUSIC. The first time you may have to build end ticks as well to account for the phone being slightly off.

I don’t know of any way to do it without involving a second device. Listening to both at once for theatrical mix will be interesting. People have been known to use half a headset.

That’s what she’s doing. The left muff has the backing track and the right ear is her voice.


You may be able to use software that creates new sound pathways in the machine. Searching.



Yep. OK. I plugged in a set of compatible headphones as a computer input device into a USB. I changed the computer Windows sound settings so by configuring that as an input device. Then, in Audacity, I set the headset as an input device.

FIXED (for now)