Audacity Only Records for Less Than a Second Then Stops

Windows 7 Home Premium SP1 64 bit.
Audacity 2.02 from .exe installer.

When using the HRT Line Streamer + to record an album all I get is less than a second of recorded sound and then Audacity stops recording. When recording directly from the PC using Stereo Mix Audacity records just fine. I have made sure the sample rate is 44.1 in the HRT settings and the Audacity settings.

Using the HRT Line Streamer + and Audacity (and all the same connectors) on my Windows XP Pro SP3 32 bit PC albums record just fine.

Any ideas or suggestions?

Make sure Snap To: isn’t checked on the bottom of the main window and make sure Transport > Timer Record hasn’t somehow been activated. Is the USB device going through a hub? Can you try a different USB connection on the same computer?

Put Audacity in Monitor Mode (Right click on the red record meters. Does the connection stay up for music? You can also hear what you’re doing with Edit > Preferences > Record > [X] Playthrough. Let us know if you can monitor it, but just can’t record it.


HRT Line Streamer +

That is a huge amount of money for an A/D converter. What is it’s claim to that much excellence?


Koz, the Snap To is not checked, Timer Record is not turned on. The USB is plugged directly into the PC and I have tried several different USB ports on the PC and the same thing happens. I can simply unplug the USB from the Win 7 64 bit machine and plug it directly into the XP machine and it will work just fine. I have even tried matching to the various Audacity sample rates to the HRT’s sample rates in the HRT’s attributes and the same problem still happens.

A friend is going to bring over his Window’s 7 32 bit laptop today and I’m going to see how it works in it.

The HRT was a gift. I’ll have to look and see just how much of a gift I was given. :laughing:

Everything worked and recorded perfectly on the Win 7 32 bit PC. It was plug and play…just like it is on my XP PC.

However, today, when I moved the USB plug from the 32 bit back to the 64 bit PC Audacity would not even record. The timing line just sat and blinked at the 0.0 mark. Audacity recorded just fine using Stereo Mix.

The Line Streamer properties were set up exactly the same as they were in the 32 bit system with the exception of matching the project rate ate 44.1 in the 64 bit PC. The 32 bit worked fine with the Line Steamer set at 96.0 and Audacity at 44.1. The allow application to take exclusive control of the device was selected in both of the PC’s.

I’ve sent HTR an email explaining the situation to see if they are aware of any issues running on a 64 bit system.

Any ideas? To help my troubleshooting, is there another recording software you would recommend I try just to see if the HRT works with it in 64 bit?

Just for testing, try Windows Sound Recorder (included as standard in Win 7

Looks like I’m not getting any sound input through the LIne Streamer + on the Win 7-64. Windows Sound Recorder did not record with the Line Steamer but it would record using Stereo Mix.

Windows Sound Recorder on the XP PC worked just fine with the Line Streamer.

Where is the sound control that I am missing? Is it a USB setting?

Here’s some praise for HRT…they replied to my email within a very short time…even on a Sunday…and sent me Win 7 setup instructions. My setup was correct except that it also showed I was not getting audio signal to the PC. Let’s see what I can find on Google…

It is probably somewhere in the Windows Sound Control Panel.
If you can’t find any incorrect settings there, post some screen shots of those control panel settings and I’ll see if I can spot anything.

Here are some screen shots of my sound settings. They match the setup instructions HRT sent me. See anything? Want to see something else?

I’ve gone down the RealTek control path and can’t seem to find a volume control panel. I can find the Dell Audio control panel and regular volume controls accessable through the speaker icon. It appears there are only RealTek drivers loaded. No simular questions or answers to my problems have been found in the Microsoft Community forums. I’m still googling it…

Thanks for your help so far. :smiley:
Sound Settings2.png
Sound Settings.png

The “Levels” slider is set to 0.0 (silence = no sound).

According to HRT that is correct because it is an unajustable line level signal. The slider does not move and the db window is not editable. That was the same setting as used on the Win 7 32 bit PC where Audacity recorded everything just fine.

And, I do not have this muted. When I do toggle the muting on and off I can see the Mute indicator also turn on and off on the HRT device.

There is some setting or some conflict I’m just missing…that’s what’s frustrating. :blush:
Sound Settings3.png

Why does the image in your last post show “Line In USB Audio Device”, whereas the image in this post shows “Line 3 Line Streamer +”

That was a screen shot of the instructions HRT sent me. The original image was the screen shot from my PC. Why the difference in names…I don’t know…maybe a clue?

It looks like they are using different drivers to you.
Did you receive an installation disk with the device or it using the default Windows drivers?

No installation disk. I have done an updated driver search and Windows says I have the most up to date drivers.

When I go into the Controller Information->Properties the Details tab does show it’s Value as a USB Audio Device. It’s named Line Streamer + in the Device Manager. I can delete that driver out of the DM and plug the device back in and the newly reloaded driver is still named Line Streamer +.

I’m going to update HRT with the same troubleshooting info I’ve shared here and see if they have any other suggestions.

Be sure to tell them that you are on 64 bit Windows 7.

Had the opportunity to try the HRT with another Windows 7 64 bit machine today that was running 7 Professional…it worked just plug and play with Audacity perfectly. Looks like I’ll have to upgrade from Home Premium to Professional to see if it will work that simply on my PC.