Audacity not seeing any signal for playback or recording, Audiobox 22VSL/Pioneer DDJ SB2/Serato

So, I’ve tried everything. In the past, I have recorded thousands of hours of vinyl through a different USB turntable with the Audiobox as my primary output device, but for whatever reason, all of the sudden, I cannot get any signal through audacity at all: from either the DDJ turntable, the Audiobox itself, etc. I’ve gone through all the steps, from enabling software playthrough, changing from MME to directsound on each of the input and output options, uninstalling the Universal Control for the Audiobox, going through the Sound Control Panel and enabling/disabling/re-enabling and on and on etc. I honestly can’t figure out what the problem could be here.

The path is as follows: The Pioneer DDJ controls the Serato software, which plays the files I am trying to record as a mix. The audio from Serato is routed to my PC audio output, which is set to the Audiobox 22VSL. I do have output through the Audiobox, and can hear it as normal.

The one clue that I think may be part of the problem is that under the “recording Devices” tab in windows Sound Control Panel, I cannot get any of the options- the audiobox, the DDJ, etc- to show a signal. Again, I think I’ve tried about everything I can. If anyone has any other ideas, please let me know.

Audacity ver.: 3.0.0 Windows 10

  1. open the run dialog with Windows logo + R
  2. enter: mmsys.cpl
  3. press the OK button

That will open the Windows Sound control panel.
Are your USB devices listed in the Recording and Playback tabs?
Does it show a signal level in the recording tab when you play a record?

When this sort of thing happens to me, I usually try rebooting - Everything. :wink: