Audacity not recording streaming audio (v3.1.x)

Hello, I have recorded streaming audio in the past (v2.x) with no problem, but since upgrading to v3.1.x Audacity does not start recording after I click on the record button… So, I thought I might find out why in a tutorial, so I looked here:

But this appears to be a broken link and (instead) redirects to:

I can record from a microphone, but I want to record streaming audio content, so I select speakers as input. However, when I select speakers as “input” Audacity does not actually start recording…

I note that the only audio input option (aside from microphone or my headset) is, actually:

  • Speakers (High Definition Audio Device) (loopback)

What does “loopback” mean in this context? If, perhaps, it means feedback from input to output - maybe this is not permitted to avoid a positive audio feedback loop? I am just guessing.

This should not be rocket science - how, then, to record streaming audio? Can anyone help?

As a suggestion, it would make for a more intuitive interface if [Streaming audio] were an item in the input pull-down list. After all, a user may want to listen to a CD at the same time as recording streaming audio in the background.

As an aside, it would seem that the [manual] tutorial_recording_audio_playing_on_the_computer.html link needs to be fixed.

Peace :smiley:
Audacity recording.png
Audacity input device.png
Audacity blank.png

Yes this link from the wiki seems to be broken. The correct link is:

and in the manual it is correct.

I have reported the broken link to the developers.

Thanks jademan:

The correct link is: > > … puter.html

From there I clicked on [Recording Computer Playback on Windows]:

From here I understand that I should set the input [Recording Device] to:

  • “Stereo Mix”, “Wave Out”, “Sum”, “What U Hear”, “Loopback” or other names, depending on your sound device.

However, I see nothing like that in the input pull-down list. Aside from the microphone and my headset, there is only one entry:

  • Speakers (High Definition Audio Device) (loopback)

However, if I select that, record does nothing. If I select any other item, I can record from either my keyboard microphone or my headset microphone.

In a YouTube video on this topic, a vlogger recommended checking that stereo mix was not disabled in:

  • Control Panel > Sounds > Recording

However, the only two items appearing there are:

  • Microphone

  • Headset

… which leads me to mention that I have recently done (at least) two Windows 10 updates since I last recorded streaming audio with Audacity. Is it possible that the problem is that Microsoft has intentionally crippled the ability of Audacity to record streaming audio?

I also checked Device Manager and all the sound drivers are active and up to date.

What else can I try?

Thanks in advance… :slight_smile:

Speakers (High Definition Audio Device) (loopback)
However, if I select that, record does nothing.

That should work if you are playing-back through your speakers but of course it won’t record anything if you are playing-back through your headphones.

It’s possible that your headphones don’t support loopback, but that would be unusual. (I assume this is a USB headset?)

Stereo Mix (which is the same as Wave Out & What-U-Hear) is getting rare on newer systems. WASAPI loopback is often the only option and if that doesn’t work you’ll need some special software.

Also, sometimes people have difficulty with WASAPI recording because it doesn’t actually start recording until after there is an active stream. Try playing something first, then start the recording after it starts playing.

Hello all, reading all your replies led me think that, perhaps, my headset was the issue. I disabled Bluetooth and tried again. Voilla, it worked!

What also led me to this conclusion was that I have discovered that if my Bluetooth headset is simultaneously paired with both my mobile phone and laptop that unexpected interactions occurred. For example, if I started to use an app on my mobile phone, then a streaming video or streaming audio on my laptop would unexpectedly stop or pause. I don’t know if these are intended or unintended interactions.

Anyway, now I know that I should not have my Bluetooth headset simultaneously paired with my laptop and another device when trying to capture streaming media.

However, in the interests of completeness, I decided to try again with the Bluetooth headset connected to my laptop, but not my mobile phone. However, the problem returned - so it seems to be the Bluetooth connection to my headset, not that the mobile phone is connected at the same time. So, I tried again after turning Bluetooth OFF. However, the problem seems to have stuck. It is late here, I will shut-down, reboot and try again in the morning.

Perhaps this is information that can be folded into the Audacity manual and the tutorial:

Maybe others who have Bluetooth headsets can try to replicate my experience…

Many thanks to you all for your kind attention.

This morning, after re-booting, I found an “optional” audio driver update in:

  • Settings > Update & Security > View all optional updates > Driver updates

So I updated that and re-booted again - with Bluetooth OFF.

After re-booting, I was able to record streaming audio again. However, I was not able to record the next audio stream.

After some tinkering, I discovered that Audacity would, however, start recording once I started the audio stream.

This is interesting, because in all previous instances I had started recording BEFORE starting the audio stream - because I didn’t want to miss the beginning of the audio stream if I started the audio stream first (in any case, I knew I could delete dead audio at the start of the recording.)

It would make sense for the recording to be paused until the audio stream actually started - but this is not how it worked previously - either recently or in past months or years.

If, indeed, Audacity is paused waiting for an audio stream to start, then, I would suggest that some kind of pop-up notification should appear to let the user know that Audacity is paused, waiting for the stream to start - something like:

  • Recording is paused, and will resume when the audio stream starts…

Likewise, if recording is paused or disabled because of some conflict related to (say) a Bluetooth audio headset - then there should be notification of that too. I have no idea what internal conflict that would be - but certainly, on my system, I cannot record audio streams if my Bluetooth headset is paired and connected to my laptop. If this happened to me, I am quite sure that others have experienced a similar frustration.

In any event, if Audacity recording is inhibited - for any reason - there should be some kind of pop-up notification to explain why recording has not started after the user clicks on the Record button: [] … such as:

  • Recording is paused, , to resume recording

Now I know the work-arounds to get around the original issue that I experienced. However, I am sure others have faced the same frustration had at the outset of this thread. This would suggest to me two actions for the development team:

  • Revise the documentation (both manual and tutorials) to identify these potential issues and give advice on how to avoid same.

  • Revise the code base to create pop-up notifications to the user to advise when recording is paused, why paused, and what to do to resume recording.

I trust that this is constructive feedback that can assist in the future refinement of Audacity.

Good idea. Perhaps this could be done for Sound Activated Recording as well. :smiley:

I now have this exact problem. I’ve recorded via loopback for several years, from things playing from various online sources. Now, as of today, the recording never starts. As far as I can see, the settings have not changed (correct speakers selected, etc.). It does not matter if the sound has started - the recording still does not begin. What has changed, and what can I look for to fix it? Very unhappy… This is with Audacity 3.1.3 on Windows 10.

Here’s what I see in the settings:

  • Host: Windwos WASAPI
  • Playback Device: Speakers (Realtek(R) Audio)
  • Recording: Device: Speakers (Realtek(R) Audio) (loopback), Channels: 2 (Stereo)

Maybe something else is running that is interfering with Audacity’s access to the sound card.
Try rebooting the computer and see if that fixes it.

If the problem persists, it would be useful if you told us what you are trying to record.

This seems to answer my issue. I would record a stream, export, and then it wouldn’t record, no change in settings. Your reply made me realize that sometimes I had the stream playing to verify that the waveform was showing or not, and sometimes I was trying to start recording with the stream paused.

Just blind luck that I found your answer.

Well, your perseverance paid off! :smiley: