Audacity not recording audio and giving error

Audacity is giving me this error:
“timestamp”: 1632683466,
“event_id”: “08260ed9ac954d22a0e989bb3737cb47”,
“platform”: “native”,
“release”: “audacity@3.0.4”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Macintosh”,
“version”: “10.16.0”
“exception”: {
“values”: [
“type”: “Error”,
“value”: “Error opening recording device.\nError code: -9986 Internal PortAudio error.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false

I am using Mac OS 11.6

I am using audacity version 3.0.4

You don’t say what you are trying to record from.

If it from one of those Super USB Cassette Capture devices, I hope you have saved your receipt. They don’t play well with MACs. If not, please say what device you are trying to record from. A MAC expert is likely to come and share his wisdom.

I’m trying to record from a cassette tape converter… one tape i did worked and the next one i tried gave me the error

What is the brand name of the device? Does it show up as “PnP USB Audio Device” or similar (“PnP” is the key) as the Recording Device in the Device Toolbar?

– Bill

Bill, it shows up as PnP USB Audio Device

As we suspected, this is one of those cheap ($40?) cassette to USB devices. No-one we know have has managed to get one to work reliably on Mac.

As jademan said, I hope you kept your receipt as you’ll probably want to return it.

If it is the only cassette player you have, an alternative is to keep it (as a cassette player) and connect the headphone output to a USB audio converter device such as the Behringer UCA-202 or UCA-222.

– Bill