Audacity not recording, after working previously, error missing .dll from shared library

I have been successfully capturing my old vinyl records over the last month with no issue. However when I attempt to record nothing is being captured. I get a flat line on the recording.
I have checked the plugs, reset the laptop, reset the turntable and no change.
I have looked in the forum for the following error I found in the logs
“error - Failed to load shared library “avformat-60.dll” Error 126 not found .”
but too be honest it didnt tell me much.

I have checked for SW updates but I am running version 3.5.1 on Windows 10.

I am happy to download any new updates or other changes or even check my laptop for this missing dll and shared library but not sure how to proceed.

I have checked other posts in the forum & if I have missed one be happy to be pointed at it.

Thanks for any help
Graeme

Update: After no success in rebooting and reinstalling SW. I found this video on Youtube which had me checking the laptop sound settings. This solved the problem as my device was disabled, I suspect due to a windows update, however I would never have checked this without the video.
Now all working.
Here is the link in case it helps anyone else.

Glad you solved it!

Just FYI - That “missing” DLL isn’t really an “error”. It’s part of the optional FFmpeg import/export library which is need for certain formats like AAC, etc., and you need it to extract audio from most audio/video files.

It’s not required for recording and If you are working with WAV, MP3, or FLAC files you don’t need to install it.

1 Like