Audacity moves the audio track after recording? [SOLVED]

Now this has been a problem to me ever since I’ve started using audacity, but I just learned to move the track after every single recording. But now that I have to record a lot of short tracks this has become a large, annoying problem. What exactly happens is that every time I record something and press “stop”, the recording start jumps a bit back - around 0.2 seconds. Why is it like that? Will a reinstall help? Any advice would be appreciated.

I think Overdub does that. Do you have Overdubbing selected in Edit > Preferences > Recording? Does it still do that if you deselect it?


That fixed it! I really liked that feature though :confused:

Reinstalling will not help.
The “jump backward” is deliberate.
The reason for it is that if you record one track, then play along with it and record another, the second track will be recorded a little bit late, due to the time it takes for the sound of the new recording to work its way from the sound card, be converted to digital, go through various bits of software and end up on the hard drive. This “delay” is called “latency”. “Latency” always occurs with all audio recording software, because nothing in a computer works “instantly”.

The length of the delay depends on many factors, including the speed of the computer, the design of the sound card, the sample rate of the audio, the sound card drivers …
In order to pull the new recording back into synchronisation with the first track, Audacity moves the new track a little to the left. Unfortunately, with standard Windows drivers it is impossible for Audacity to know exactly how far to move it, so it guesses (the default is 130 ms). This is called “latency compensation”, and it is adjustable to suit your system. The setting is in “Edit > Preferences > Recording” and is called “Latency correction”.

To make the track move further to the left, make the number more negative.
To make it move less, make the number less negative.
To not move at all, set it to zero (or turn off overdubbing in the Transport menu).

I see. Is there any way to find the perfect latency correction time, or will I have to do it by ear?

Note that if you turn off overdub, you will not be able to hear what is recorded in other tracks while you are recording a new track (OK if that is what you want).

There’s instructions in the manual:
Note that for some systems the latency may vary a little each time you record, but if you can get it to within a couple of milliseconds that is usually close enough.
To get it reliably exact you need better than “consumer level” gear (though some consumer level gear can be surprisingly accurate).

Yess! Thanks a lot! It was only off by around 30 milliseconds but now it’s perfect.