Audacity messing up volume control system wide.

Audacity 3.1.3
Fedora 35


I had not used Audacity for a couple of years but I’ve not had this issue before.

I usually control audio volume with a little widget on the taskbar. This works fine of video ( eg utube ) VLC and wav files.

Yesterday I did a bit of work with Audacity which said it needed Jack ( it seems to have started this automatically if it was not already running ).
IIRC I had to run PulseAudio Volume control which I found on the system menu ( I’ve not used this before ) to set mike input levels and select it as the source.

At that point the volume “mixer” widget stopped having any effect on audio output.

All videos are too quiet so I need to set them with PAVC. Sadly this is not persistent and every time I run a new video or audio source I need to reset the value because it bounces back to 100% ( too quiet ).

After some rather fruitless googling I discovered my Fedora system is now using pipewire instead of jack. I thought this may be the source of the problem so I tried installing jack , which automatically uninstalls pipewire.

dnf --allowerasing  install alsa-plugins-jack

That did not help. Same behaviour. This suggests that it is neither jack nor pipewire so I’m back seeing this as something Audcity has done , either directly or indirectly.

I’m sure I’m not the only one with this kind of issue. It seems, after being pretty stable for a long time Linux sound is causing lots of problems.

If I reboot, things work OK until I run Audacity. :frowning:

Can anyone point me to the cause and what to do to fix this?


As far as I’m aware, Pipewire is not yet fully supported by Audacity.

Audacity can use ALSA, or ALSA + PulseAudio, or Jack (jack1 or jack2).
I’m on Xubuntu, and by default Audacity uses “ALSA + PulseAudio”. (ALSA provides the low level drivers, and PulseAudio manages audio on a higher level).

When PulseAudio is installed as the default sound server, Audacity’s levels can be controlled using “PulseAudio Volume Control” (pavucontrol). PulseAudio Volume Control is often the default mixer on systems that use PulseAudio as the default sound server.

On a “ALSA + PulseAudio” system, PulseAudio accesses the sound hardware via the ALSA drivers. Normally it is not necessary to access the ALSA mixer directly, though you can check ALSA’s mixer settings using “ALSA Mixer”. In a terminal window, enter:


to launch the mixer in the terminal. (“Esc” to quit).

It is “possible” to use Jack and PulseAudio at the same time, but doing so requires additional modules to be installed, and it can be tricky to set up correctly. I’d recommend NOT attempting this until you are comfortable working with PulseAudio.