Audacity manual permissions problem

I’ve tried following the instructions for downloading and installing a local copy of the manual, but Audacity would not recognize it.

The files were all there under /usr/share/audacity/help/manual but it seems the permissions were wrong.

This works…

sudo unzip <> -d /usr/share/audacity/

…but using a root instance of Nautilus (gksu nautilus) and either Nautilus’ Extract Here or opening the zip in file-roller and extracting it results in the files being only accessibly by root (i.e. drwx------ / 700 instead of drwxr-xr-x / 755).

Perhaps it would be better if the manual only suggested the command line method.

Ubuntu 14.04.2
Audacity 2.0.5

Thanks for the report.
Yes, the same happens for me with the “alternative” instructions, though the primary instructions work.

This works:

Try running a sudo unzip command from a terminal ( for example, sudo unzip ~/Desktop/ -d /usr/share/audacity/ )

but if I do:

Alternatively, launch your favorite file manager with root privileges ( for example, sudo nautilus ), unzip by right-clicking the downloaded file then close the terminal and file manager.

then I had to also set read permissions for “others” else the permissions end up as root access only.

It’s too late to change that in the current manual, but I’ll change it in the alpha manual so that it will be fixed in the next release.

I’ve ended up here via google as I can’t get Audacity manual to work within the program.

I have Audacity 2.0.5 on Linux Mint 17 Qiana. I am an XP refugee, still barely above total noob on Linux, floundering my way forward, so I am sure the problem is some configuration issue.

After apt-get install audacity, I tried help, but it said it wasn’t configured and told me to download.

I downloaded the help manual, and extracted to a help/manual/… structure in downloads. I then sudo cp this to /usr/share/audacity, where there are already nyquist and plug-ins folders, which looked promising. Trying to access help from within the program again gave the same error message as before.

I noticed the permissions on help were different to the existing folders, so I sudo chmod -R to rwxr-xr-x. The owner of the files was root, as for the nyquist and plug-ins folders. Now trying to access help, I do not get an error message, but I get nothing else either. No lock up of the program, but no help appears.

I deleted the help folder, and tried the alternative route listed above, sudo unzip -d /usr/share/audacity/, which achieved in one step what had taken several before, a help folder owned by root with rwxr-xr-x permissions in /usr/share/audacity. The audacity behaviour was exactly the same as before, nothing happens when I click on the help menu entry.

I notice that the help is delivered via a browser. I am using Chromium (Version 41.0.2272.76 Built on Ubuntu 14.04, running on LinuxMint 17). Am I perhaps missing some setting to tell audacity what to use? I don’t see any entry for this in either preferences or the help menus. I know that stuff can lurk in /etc and other places, but wouldn’t know what to look for.

The Audacity help menu simply links to the html help files, so your system should open them with whatever program is the default application for opening html files.

To check that your browser is set up correctly, find any html file (for which you have read access) and double click on it. Does it open in your web browser?

Let’s check the file location and permissions.
Find the “help/manual/index.html” file that you have installed. Right click on it and select “Properties”. What does it say for the “Location”? Now select the “Permissions” tab - what does it say (all of the information in that tab)?


Must control my panic and think. I have only ever used the browser from within itself, so hadn’t noticed that general html files weren’t opened by it by default. Sorted. Thanks very much.

My next task is to find out where that sort of default behaviour is observed and controlled from the command line, rather than depending on a gui tool.