Audacity locates older versions of FFMPEG libraries

Good day,

I’ve installed FFMPEG v6.0 from source on Pop!_OS v22.04:

But Audacity 3.3 still shows the older version of FFMPEG libraries:

I tried to locate the file manually, but apparently I don’t have it onboard, only the older version(s):

How can I update Audacity to use the newer versions of FFMPEG libraries? Thank you!

General instructions for loading FFMPEG are here: Installing FFmpeg - Audacity Support

If you need to install the bleeding edge, see here: compiling-other-versions

Thank you! In fact, I have learned about your general instructions before installing FFMPEG, but they don’t cover, AFAIU, installing FFMPEG from source, as it was in my case.

As to the “bleeding edge” compilation, I cannot find the file avformat-*.dylib among the installed files, as instructed on the webpage you shared above (btw, aren’t these instructions for macOS? Cuz Linux instructions on the same page are slightly different). Nor can I find the latest file avformat-*.so on my rig to point Audacity to use it, only the ones I showed in my original post.

In short, I’ve successfully installed the latest version of FFMPEG (6.0) from source but cannot locate the latest version of avformat*.so on my computer to link it to Audaicty.

Thank you!

From what I understand, Audacity uses a special version of FFMPEG that’s been tweaked to integrate with Audacity.

But you may be able to use another version as an External Encoder.

@DVDdoug thank you very much indeed! That’s a valuable option too.

After some more research, I’ve finally solved the issue as follows:

1- Used ./configure --enable-shared instead of simply ./configure during FFMPEG installation. In short, this makes sure that is “visible” to the system and can be located through Preferences -> Libraries -> Locate;

2- Thanks to this article, fixed the loading of shared libraries properly to make Audacity recognise the latest versions of libraries.

This topic was automatically closed after 30 days. New replies are no longer allowed.