Audacity linking of port audio

hello there,

I am porting an audio app from MacOSX to Ubuntu. It uses portaudio.
So I downloaded portaudio, compil it and install in /usr/local, as recommended.

Later, I downloaded Audacity and install it (binary only, not the source)
When launched, Audacity fails, complaining for an unresolved symbol in portaudio lib.

I could see that there were other portaudio libs in /usr/lib/x86_64-linux-gnu/
probably installed by Ubuntu.

If copied these in /usr/local/lib, overwriting those I compiled.
And Audacity could work.
But this is not a solution, because I have often to compile portaudio with various options for my own dev.
Yes I could install portaudio elsewhere than /usr/local, but that look weird.

This is a generic problem : how can I use /usr/local for developing purpose, modifying some libs as I need,
and still be able to use common applications like Audacity,
which relies on /usr/local contents ?


Do you really mean when launched, or when you tried to compile Audacity?

If you mean when compiling, were you configuring Audacity with local or system portaudio?

What exact version of Ubuntu are you using?

Have you tried configuring Audacity to use portaudio supplied with Audacity?


If you have more problems please attach the complete configure log and make log.