Audacity keeps stopping randomly


So I’m new here. Let me know if I’m posting this in the wrong section or something. I am using Audacity 2.0.6. I record let’s play videos for a YouTube channel and have for about a year now. I started using Audacity for my voice months ago and had not experienced any real problems with it until recently, about a month ago. My recording keeps stopping suddenly, without any prompts from me or anything. I have tried to determine what could be causing it, but it is happening pretty randomly. One time, it stopped after I muted my mic to change my kid’s diaper. Another time it stopped after I hit Escape to pause my game. This most recent time, It seemed to stop without any prompts at all. Literally, just in the middle of my game. Audacity does not close; it just stops the recording. If anyone knows what could be causing the problem, I would really appreciate the help. This problem has literally ruined hours of work. Thanks.

Which Windows?

You’re recording a YouTube presentation and a game and your live voice? I can easily imagine some of the Audacity control keystrokes overlapping the other events. Audacity traditionally Doesn’t Play well with Others. It assumes it’s the only audio program running and has no provision to survive control collisions. If you’re going to record a game with your voice, I believe FRAPS is recommended.


Well, I am recording a Game and Audacity. I edit the two together for YouTube. Is there a way to turn off all key strokes? FRAPS is my recorder of choice for gameplay, but trying to add my audio to it has been very unsuccessful. Mostly, because I cannot edit how loud my audio is, compared to the game’s audio. If you know of any other software I could use to replace Audacity, I would love to try it out. As of right now, I literally just lost an hour and a half of footage. It was the conclusion to a series I was playing, so it was a pretty big deal. Audacity apparently stopped recording after 6 seconds and destroyed all of it. Like, you can’t exactly recapture your first reaction to a conclusion. It is really unfortunate. I’ve used audacity for a while and never had a problem. It has only recently been an issue, but it’s a very severe issue. If I can’t find a solution I will have to remove Audacity altogether.

Audacity can’t turn off any global shortcuts (shortcuts that work in all applications) that are set by other applications. You have to turn off global shortcuts in the application that set them.

You will probably need to turn down the volume of the in-game sound so that your mic can be heard.

If you just want to record your mic, you can use any recorder, even Windows Sound Recorder. You have not said what version of Windows or what type of mic it is. Is it a USB headset?

If you want to record the game and the mic, try VoiceMeeter:

When you say “destroyed all of it” are you saying the blue waves disappeared leaving a flat line? That is usually caused by either a dud drive or a temporary file cleaner. If that’s the problem, try File > Save Project As… before starting the recording, saving to a permanent location with at least several GB of space.

If the blue Pause button activates when recording stops, turn off Transport > Sound Activated Recording.


I went through the settings and disabled all the command keys, so only my mouse could do anything. It still ended up shutting off. I don’t think it’s an issue of incompatibility.

Yes, that does work for some games, but others do not allow the volume to go down adequately. Basically, it works for some games, such as minecraft. But other games, especially horror games, or even FPS’s are simply too loud. I can use it as a solution for some games, but I need a long-term plan. Audacity, up until now, has done the trick. I also know a number of other YouTubers who regularly use Audacity.

Ok thanks. If I can’t get this working I will try that. I am using Windows 8.1. Sorry, I thought I mentioned that at the beginning, but apparently I just left it out. My bad :stuck_out_tongue: The mic I’m using is a USB Blue Yeti.

Thank you. I will check it out :slight_smile:

When I said “Destroyed all of it” (Somewhat over-dramatically…), I meant only that I was unable to use my FRAPS recorded footage, since my audio was not saved. It didn’t really flatline…It just stopped. It was like I hit the Stop button on the top in the middle of my video. The footage recorded was only 15 seconds long, or something.

I will check that out next time it happens.

Someone suggested to me it might simply be a glitch with my Audacity. Embarrassingly, I have not tried uninstalling and reinstalling. So I guess I’ll try that first and see if that helps the issue. Sorry, I should have done that from the beginning. I’ll try that and then let you know how that goes.

Do you have a non-USB mic to try? USB streams can just “run out of resources” and dry up when the computer is being pushed hard.

Keep Windows Task Manager open when recording and see what happens to CPU and RAM. audiodg.exe (needed for audio playback) can leak memory on some computers, though it happens mostly on Windows 7 or before.

Make sure you enable the option in the installer to “Reset Preferences” or your settings won’t be changed.