Audacity is "stuck" at zero and won't record

I am having a very frustrating issue with Audacity.

It was working perfectly until yesterday.

I am working on a multi-track recording and want to add the piano track. I add a new mono track, hit record and the red “record head” just is stuck at zero and won’t budge. I don’t get any playback of other tracks. Nothing. When I stop the recording I sometimes get a cryptic message about latency and other times, no error message at all. But still nothing has recorded.

I tried monitoring the sound and it’s working… I couldn’t figure it out so I started a new project and hit record. It works perfectly recording the piano.

I go back to the original project. Still not working.

Then I started a new project and created a click track (rythym track) before I added a second track and hit record. STUCK!! Not working again.

It will record the piano only if there are no other tracks recorded… But I never had this problem before.

I have shut down the computer several times. No difference.

I am using a Roland Rubix 22 USB Audio Interface.

What is going on???

Are you recording a real (acoustic) piano with microphones?
What are your settings in the device toolbar?
Which version of Audacity (look in “Help menu > About Audacity”).

I am recording from a Roland electric piano via patch cable to the Roland rubix.

Windows 10 and just upgraded from audacity 2.2.1 to the latest 2.3.2 to try and fix the issue but no luck.

Oh and i out device is the rubix 22. Output I have tried all three settings, headphone, Microsoft mapper and rubix. Makes no difference to this problem it seems. Rubix gives me cleanest output though.

Try setting the “host” to “MME” in the device toolbar, then set the recording and playback devices to the Roland.

It is set to MME. Sorry, didn’t mention that setting. I have now tried changing it to the two windows settings as well, but still no charge.

Look in “Transport menu > Transport Options” and ensure that “Sound Activated Recording” is turned off (not selected).

Yes I had already checked that setting and it is not on.

Shut down Audacity.
Power down the computer (completely).
Check the USB cable is securely plugged in at both ends.
Restart and try again.

Have tried that multiple times but doesn’t help.

It will record just fine for one track.

When I add a second track, that’s when it gets stuck.

Check the device settings (Recording and Playback) in the Windows Sounds control panel. Ensure that the Rubix is set to “2 channels (stereo)” and “44100” sample rate in both the Recording tab and the Playback tab.

I also have Windows 10, though I was using Audacity 2.0.5 at first with a Rode NT-USB microphone. I downloaded the latest version of Audacity (2.3.2) to see if that fixed it, and all it did was nix the error message.

Error message in full:
“Latency Correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool (<—> or F5) to drag the track to the right place.”

This was for anything. I tried to record with no previous tracks, the time arrow turned red and refused to move. I tried to record with a click track in place, that didn’t work either. Moreover, when I tried to PLAY the click track, all I got was static.
That’s when I went to the newer version. Got the same results, minus the error message. Tried it with an old audio doodle I did with “Man on the Silver Mountain” to the same result: couldn’t record. Tried recording in the middle of the song using the Time Selection tool, time line still wouldn’t move. Playback still yielded nothing but static.

However, it was then that I noticed that the playback speed was very, VERY slow, about 50x slower than normal (.02 seconds of playback time for every 1 second of real time). I switched from MME to Windows Direct Sound and got similar results, but when I switched to Windows WASAPI, the tracks played back as normal.

I then of course tried to record something, but was immediately given a new error message:
“Error opening recording device
Error code: -9997 Invalid sample rate”

I attempted to troubleshoot via the “Error opening sound device” Help page, but everything seemed in order. When I turned Overdub off, I was suddenly back to the time dial not moving, albeit at the very END of the song where the other tracks cut out.

My drivers are all up to date, the toolbar is currently set to Windows WASAPI for the sound processor (or whatever the MME/Windows WASAPI is called), RODE NT-USB for the microphone with 2 (Stereo) Recording, and Realtek High Definition Audio for the Speakers/Headphones. I checked the frequency on both the microphone and the speakers, and set them both to 44100 (microphone was set to that already). Still no recording, still no playback with MME.

Also, every time I change from MME to WASAPI or back again or any other combination , Audacity sits there and goes “(Not Responding)” for a bit before fulfilling the command.

I gave up and downloaded pro tools. Works great.

That error message in older versions of Audacity, was a bit misleading because it describes a symptom, not the cause. What it meant was that the recording stalled, leaving a very short, or zero length recording hidden to the left of time = 0. The important part is that “the recording stalled”.

In Audacity 2.3.2, if the recording stalls, it does not leave a hidden fragment (hence no error message), but you are still seeing the same problem of the recording failing.

We didn’t get to the bottom of the problem with Mark, but I suspect the problem was due to ASIO running. Audacity does not ship with ASIO support (due to license restrictions). If ASIO is not running, setting up Audacity to record from a USB microphone and play through the built-in sound card should be as simple as:

  1. Connect the mic (you can check that it is connected and working by looking in the Windows “Sound Control Panel”)
  2. Launch Audacity (note that this is after connecting the mic).
  3. In the “Device Toolbar” (, set the “host” to “MME”, the “Recording device” to the USB mic, and the “Playback device” to the internal sound card.

and that’s all.

Other common problems:

In recent versions of Windows, Audacity must be given permission to access the microphone (to access any recording device). See:

Ensure that Skype (or any voip app) are not running, not even in the background. Skype attempts to grab exclusive control of the sound system, which prevents other applications from access the mic.

Is there a way to stop ASIO from running? Because I ensured the microphone had permission, I made sure Skype wasn’t doing anything, I set the toolbar to the settings you suggested, I even swapped back to my old microphone and the problem still persists. Although, I noticed that the recording was doing the same thing as the playback, going 50x slower time than normal.

So long as no audio applications start up on boot, you can just reboot.

In addition to ASIO and Skype, another possible interfering app is Shockwave / Flash. If you have any tabs open in your web browser, they could be loading Shockwave / Flash, which could grab control of the sound card. After rebooting, try starting Audacity before using your web browser.

I’m also having this issue. I have tried all the suggestions in this thread, but it still won’t record. :angry:

I did update Java beforehand. Could that be the culprit?

Can you hear the Roland electric piano playing through the Roland Rubix?

That’s not me. I’m having the same issue as the OP. I can record one track by itself in a new session, but I cannot record if I load up a previous session with multiple tracks. It just stalls. I’ve tried different versions of Audacity, but still having the issue. Like I said before, I’ve had to make specific mixes to overdub to in other programs, but I like Audacity the best because it’s east for me. I’ve posted on Reddit about this as well.

As you are using different equipment, and we don’t know what you are trying to record, and we don’t know your settings are, and we don’t know which version of Audacity you are using … It would be better to start a new topic and tell us all about your setup, what you are trying to do, and what you see happening.