Audacity is Skipping in my Recordings! Help!

I have a MacBook Pro, very capable of recording my voice, I use a Blue Snowball to get the best quality I can afford. But now out of the blue, Audacity will not record everything I say. I can talk for about a minute and then it will cut off and come back but completely skip an entire portion of what I have said. I typically talk for 4-5 minutes at a time for Live Commentaries, Etc. I have adjusted the settings and reduced the bit from 32 to 16 and from 2 audio recordings (Stereo) to 1 Recording (Mono). But the skips still keep happening. I can’t find any help and I am running out of time. Please help.

Which numbered Audacity do you have? I’m running 2.1.2.


Do you have enough drive space for the work?

But now out of the blue

As a drive starts filling up, it has a harder and harder time finding room to put the work. This is assuming you didn’t change anything else.


2.11, I am downloading 2.12 now. I hope that was the issue

I believe so, I have roughly 140 GB and I am pretty sure that is not why it’s skipping :frowning:

So…I downloaded 2.1.2 and it is still skipping. IDK what to do, I am very frustrated with this software, but I need its ability to reduce background noise for my commentaries. I have been trying all day to fix this and nothing is working, I have to put out a video but due to this ISSUE, I can’t. I have plenty of memory, only Audacity and my recording software is open, and I am not even connected to the internet. I am beyond pissed off, and wish that the creators of Audacity would tell us how to fix this.

What is the other recording software exactly? Is that recording game sounds?

Have you rebooted the computer yet?

Are you sure you have the latest OS X 10.11.6? The first El Capitan and some other versions have serious USB problems.

Note that on Mac, you may have to reduce Audio to buffer in Audacity’s Recording Preferences, not increase it.

You can use GarageBand instead of Audacity if you blame Audacity for the problem.


Elgato and I use either iMovie or AfterEffects for editing depending on the video type. But I will only have 2 of the 3 open at the same time.



I just reduced it and will see if it works, should I make the latency correction close to 0? It is sitting at -130?

I may just have to if the issue continues.

It’s not latency. It’s the other setting, Audio to Buffer. Latency adjusts timing when you sing multi-pass overdubbing.