Audacity is not able to record sound from AureonXFire8.0HD

I am running Audacity 2.0.5 under windows 8.1 x64 (with all available updates). My input device is SPDIF-In from Aureon XFire 8.0HD (USB connected, with Terratecs top actual software Terratec_AS372_20140227). If I push the record button, recording does not start. I can see in Help / Info to Audio devices the follwing text: “Selected capture device: 29 - SPDIF In (AUREON XFIRE8.0 HD) - Selected playback device: 8 - Lautsprecher (Realtek High Defi Supported Rates: 48000 - Unable to open Portmixer”.
I think, there is a problem in Audacity because it is not able to open the Portmixer. What can I do?
Kind regards hw1104

As I understand things, the Terratec Aureon XFire 8.0 HD is driven by ASIO drivers. But Audacity does not support ASIO as shipped. There might be a problem right here.

This said, you could try connecting the Terratec Aureon XFire RCA line-out to the line-in on your PC, if any. This kind of connection usually gives best results.

Also you could try recording using WASAPI. Have a look at Recording Computer Playback on Windows


Thanks for your help - but running an older Version of AUREON XFire 8.0 HD and Windows7 (x86) and an older version of Audacity all was running very well. Or do you think that ASIO Support was removed in Audacity 2.0.5? And I would like to use Optical In because of Quality.
Kind regards hw1104

No versions of Audacity have ever been released with ASIO support.
Although it is possible to add ASIO support to Audacity by building Audacity from the source code, this requires using Steinberg’s ASIO SDK. Unfortunately there is a licensing conflict between Audacity’s open source license (GPL v2) and Steinberg’s “non-distributable” license, which means that building Audacity with ASIO support must be for the personal use of the person that builds it only. Downloading the Steinberg SDK requires signing a legally binding agreement to their terms.

Assuming that you were using an official release version of Audacity, your audio device must have been using standard Windows drivers in order to work with Audacity. To use Audacity 2.0.5 (or any release version of Audacity) you will need to have standard Windows drivers for the device installed.

In the Windows Sound Control Panel, look to see if the AUREON XFire is listed as an available device. If it isn’t, have a look on your AUREON XFire 8.0 HD installation disk and look to see if there are “WDM” drivers. If there are, install them and reboot your computer.

Whoops, my bad!
There are ASIO drivers for the Terratec Aureon XFIRE8.0 HD, but Windows drivers are also available. You’ll find drivers for Windows 8.1 x64 at AUREON XFIRE8.0 HD

Hi, I had installed the Driver for AUREON XFIRE8.0HD from this source!
Kind regards

What do you mean by an older version of AUREON XFire 8.0 HD? Do you mean an older driver version from Aureon? That is a possible explanation.

If the Aureon appears as an icon by the system clock, click the icon and see if it has its own control panel where you can choose other than ASIO drivers.


the Hardware is the same as before, but because of Windows 8.1 I had to install the newer driver. Near the clock I can see Aureons Control Panel, but I do not see a possibilty to choose a Driver. If I push the ASIO button I see the possibilities to choose the bit depth (screenshot 2).
Kind regards hw1104

If there is a printed Manual for the device, you could look at it. There is no useful information online.

What exactly happens when you record with Terratec and Audacity now? Do you see “error opening sound device” or do you record silence?

If the newer Windows 8.1 driver for Aureon only exposes ASIO drivers then Audacity won’t work with it. Did you actually try the older drivers that worked with Windows 7? Those drivers might be OK for Windows 8.1. The audio system did not change substantially between Windows 7 and Windows 8.1.

Also there may be a way to have Audacity accept input from an ASIO device without compiling Audacity with ASIO support. You could try VB-Audio ASIO Bridge from (half way down the page). I don’t know if anyone has tried doing that, but if it works, the ASIO stream from the Aureon could be routed to an input called “Hi-Fi Cable Output” and you would then choose the “Hi-Fi Cable Output” as the Audacity recording source.



  1. There is no printed Manual for AUREONXFire8.0HD.
  2. AUREON XFire8.0HD did not run with the old (Windowss7) AUREON software under Windows 8.1. This was the reason, to install the new AUREON software.
  3. If I start recording,what happens? Nothing. After a while I stop recording and than I made a look into Audacitys Help: Please look at my first entry. And nothing was recorded, no noise, no silence, realy nothing, the duration is 0.
  4. Your last recommendation I will try later, this is not my first choice.

Next I will ask AUREON for a nonASIO-Driver.
Kind regards

There is a Manual in German available from TERRATEC Audio Center High Definition Audio Benutzerhandbuch
A manual in English from TERRATEC Audio Center High Definition Audio Device User Manual

Thanks for looking. I did find that page before but couldn’t find anything specific to the Aureon 8.0.


The official manual is available from TERRATEC_AUREON_XFIRE8.0_HD_Manual_TERRATEC_Audio_Center_EN.pdf
And the setup guide from TERRATEC_AUREON_XFIRE8.0_HD_Quick_Setup_Guide.pdf