Audacity is crashing during MP3-Conversion


When I try to batch-convert (Normalization & MP3-Export) a specific album, Audacity is crashing with this error message:

These files are from iTunes, in m4a format. I’ve tried different things, renaming the folder, converting the files with another tool to FLAC and WAV, but nothing helps. Audacity keeps crashing.

OS is Windows 10 64bit 22H2.

Normalisation and FLAC-Export works perfectly well, so I guess the error has something to to with the MP3-Export function.

That’s weird - “assert” errors are usually restricted to “debug” builds. Are you running a debug build?

No, it’s the current final version. 3.2.2.

Where are you exporting the file to?
Does the file name or metadata contain any “special” characters? (characters other that a-z, A-Z, 0-9, space, underscore).

File name is The Meters - 02 - Here Comes the Meter Man and it happens in both cases: when I use the batch conversion and when I try it manually (saving to the desktop). Every time during the exporting progress. By the way: same error with the Audacity installed on my notebook.

Re you able to export other projects as MP3?

Yes. I’ve bought two albums from iTunes and the other one worked perfectly fine with Audacity.

Should I install the new version 3.2.3?

The one that does NOT export as MP3 - are you able to export it as WAV?

Yes. Same with FLAC.

After exporting as WAV, can you import the WAV file into a new project and then export as MP3?


I know it’s only a workaround, but it would seem that there is some sort of minor problem with that particular iTunes file that LAME (the MP3 encoder) doesn’t like.

Maybe, at least it seems so.
Should I upload the file, maybe you can reproduce it?

You should not make the file publicly available as it will be subject to copyright, but I’ll send you a PM (link to private messages is top right).