Audacity & iPad


J’ai enregistré un texte sur mon iPad en utilisant l’application Mic Pro qui m’a sorti un fichier en .aif. Pour le “nettoyer” j’ai ouvert Audacity, et voici les pistes que je trouve (voir attachments)….inaudibles donc.

À noter que toutes mes autres applications (VLC, ocenaudio, QT, iTunes, Flip player,) lisent le fichier sans problème. Ocenaudio refuse cependant de l’exporter en .aif et se bloque, mais veut bien l’exporter en .wav, et là il n’y a plus de problème avec Audacity qui l’ouvre et présente des pistes “normales”. Je pense que le problème vient de l’application de l’iPad (Mic Pro téléchargé sur iTunes store) qui adjoint un codec ima4 avec d’autres bizarreries que l’on trouvera ci-après, notamment la durée de 324ms…et débit global: 24,1 Mb/s….

Mais avant de jeter l’application j’aimerais comprendre.
Merci pour les suggestions,

I recorded a text on my iPad using the Mic Pro device which gave me a .aif file. To “clean” it I opened Audacity, and here are the tracks that I find (see attachment)… inaudibles.

Note that all my other applications (VLC, ocenaudio, QT, iTunes, Flip player,) read the file without problem. Ocenaudio however refuses to export it in .aif and crashes, but allows to export it to .wav, and there is no problem with Audacity which opens it with “normal” tracks. I think the problem is with the iPad’s device (Mic Pro downloaded from iTunes store) which joined an IMA4 codec with other oddities that are given below, including the duration of 324ms … and the global throughput : 24.1 Mb / s …

But before throwing away the device, I want to understand.

Thanks for answering,

Voici l’analyse de Mediainfo:

Nom complet : /Users/name/Desktop/père noel.aiff
Format : AIFF
Format/Info : Apple/SGI
Taille du fichier : 952 Kio
Durée : 324ms
Type de débit global : Constant
Débit global moyen : 24,1 Mb/s
Format : PCM
Identifiant du codec : ima4
Durée : 324ms
Type de débit : Constant
Débit : 24,0 Mb/s
Canaux : 2 canaux
Echantillonnage : 44,1 KHz
Profondeur des couleurs : bit0
Taille du flux : 948 Kio (100%)
père noel auda2.aiff (868 KB)

The file is just garbled voice on Windows, even in VLC. MediaInfo on Windows gives the correct length of just over 5 seconds and that length is consistent with the file size if it really is PCM audio.

If you can export it as a listenable WAV file in other applications, obviously do that.


I cannot post the original file, it’s too heavy to attach it for the forum. So what I have attached is the cut file with Audacity. The file you see or listen to, is what Audacity shows. If I try to cut it with ocenaudio, I can only export it in .wav or other code, but the original file is changed and lost…

The MediaInfo analyse on my post, is the analyse of the original file.

It’s not very important, the only question is: why Audacity opens this file in that way, whereas other applications opens it so I can listen it at least.

Thanks, regards,

I did not understand that the file you posted was not the original file.

AIFF/AIFC files will import using the built-in libsndfile importer by default. IMA4 is Apple’s implementation of IMA ADPCM. Libsndfile will only accept IMA ADPCM in WAV files, not in AIFF/AIFC, as shown in the table at libsndfile.

So to import this file directly into Audacity, I suggest you use File > Import > Audio…, and in the “File type” list, choose “QuickTime” files. Then the file will import using the Mac’s QuickTime importer instead of libsndfile, and if QuickTime Player can play it correctly, Audacity should do so.


I tested. Audacity does not recognize a QT file under .aif nor .aifc and refuses the importation.

But, having changed the file with QT into .aifc, Audacity opens the file correctly that it is by Importer>Audio (Any file), or Fichier>Ouvrir (Any file), or by “Open with” while clicking (right click) on the file.
Moreover, I manually changed in Finder the file into .aifc, therefore without passing by QT, and Audacity opens it there too correctly.

Solved problem. The mystery of the codes and codecs remains whole.
(Systran traduction)

Thanks a lot, Gale.

En français.
J’ai essayé. Audacity ne reconnait pas de fichier QT sous .aif ni .aifc. et refuse l’importation.

Mais, ayant changé le fichier avec QT en .aifc, Audacity ouvre le fichier correctement que ce soit par Importer>Audio (Tout fichier), par Fichier>Ouvrir (Tout fichier), ou par “Ouvrir avec” en cliquant (clic droit) sur le fichier.
Du reste, j’ai changé manuellement dans le Finder le fichier en .aifc, donc sans passer par QT, et Audacity l’ouvre là aussi correctement.

Problème résolu. Le mystère des codes et codecs reste entier.

Did that QuickTime conversion make the file much larger)? If so it changed it into PCM instead of ADPCM and that would be the explanation.

Also you did not say which version of Audacity you have. If you have the old 2.1.0 version, nothing happens when you import an AIFF file of any kind, unless you have FFmpeg, due to a bug.

You can always look at Help > Show Log… top right of Audacity to see what importers tried to import the file.

You mean you renamed the file from .aif to .aifc extension? You could look at the log (as above). Perhaps FFmpeg (if you installed it) imported the file after the name change.


No, the file “weighs” about 949 Kio and the format is always PCM

Yes. Usually when one makes this kind of change of extension of file, the computer requires confirmation, but there nothing, the extension is changed without warning.

I made the same operations with Audicity 2.1.1 and 2.1.2

I put in the attachments the reports from bugs log:
01 = manual change of extension of the original file
02 = change carried out by QT of the original file
03 = original file .aiff

01 log perso aifc.txt (1.58 KB)
02 log QT aifc.txt (1.57 KB)
03 log vo aiff.txt (1.57 KB)

Thanks for the log files. As you can see, libsndfile takes the “.aiff” file. This is not an Audacity bug. As I explained, libsndfile cannot cope with IMA ADPCM in AIFF files.

When the file has “.aifc” extension (after “conversion” by QuickTime or rename in Finder) the log shows that FFmpeg (libav) takes the file.

Perhaps if you used File > Import > Audio… in Audacity then choose the “FFmpeg-compatible files” filter, the original AIFF file would import correctly.

I don’t understand why the original AIFF file would not import correctly when you chose the “QuickTime files” filter in File > Import > Audio… . After all, QuickTime on the Mac could play the file. But we can’t look into that unless you can provide the original file. You can use a free file sharing service and post a link to the file. For example:

When using file sharing sites, avoid clicking on advertisements that have download or other buttons.

Or record another .aiff file not over 2 MB on your iPad and attach that, if it shows the same problem.


It works that way!

“Or record another .aiff file not over 2 MB on your iPad and attach that, if it shows the same problem.”

Here it is, with the same characteristics.

5 secondes.aiff (249 KB)

I had forgotten, but we don’t specify AIFF, AIFC (or AIF) extensions as normally importable by QuickTime, so files with those extensions are greyed out in our import dialogue. I think that’s a mistake, so I created an issue report and a possible fix here


The problem will thus be solved…. with a forthcoming version of Audacity. And for me the question of the codes and codecs is a little less opaque. (I’m not quite sure of that… :mrgreen: )

That said, why preserve this Quick Time filter in the “Type file” choices of opening or importation of file….since QT itself opens only formats approved by Apple, and that these AIFF/ima4 files open by using the filter of the ffmpeg suite.

Thanks again,

They do, but you did not know that, so had to ask here for help. It could be the same for other users.

And FFmpeg is an extra download, whereas on Mac, we are aiming to offer import of formats that QuickTime can open without the need for an extra download.