Audacity has stopped recording [SOLVED]

Hello. I’ve been using Audacity to record audio from the internet for about a year. About a month ago I upgraded to 2.0.6 (from 2.0.4) w/o any problems. It continued to work fine till about a week ago, when it stopped recording completely. Nothing seems to be set wrong, but when I press Record with audio/video playing, I get no recording level indication and no audio track info (it straightlines). I’m using Win 7 64-bit Home Premium SP1, Realtek HD Audio, and Stereo Mix is enabled (and marked as the default device) under Recording Devices.

Within Audacity, Audio Host is set to “MME”, Playback Device is set to “Speakers (Realtek HD)”, Recording Device is set to “Stereo Mix (Realtek HD)”, and Recording Channels is set to “2 (stereo)”. In the Preferences: Recording dialog, Overdub, Software Playthrough, and Sound Activated recording are all unchecked, while .

What’s weird is that it was working fine, I’ve changed nothing (though Windows did some security updates around the time it happened), and now suddenly it won’t record at all (not from the internet, nor from a program like VLC Player or Windows Media Player). The sound driver appears to be original (dated 3/17/2010).

I’ve read through the tutorial and FAQ, but see nothing that looks helpful in this situation because I don’t believe I’ve done anything to cause an issue so I’m leery of making massive changes to what should be working. I’m completely stumped.

Any ideas on what my sudden problem might be? I really need to resolve this thing. Thanks in advance for any help you can provide.

I assume you still have the Audacity input slider turned up.

Are you playing the audio you want to record on “Speakers (Realtek HD)”? If not, for example you plugged in a USB headset, that’s a separate audio device, so Realtek stereo mix can’t record from it.

Windows Update “could” have changed the audio drivers for the worse, see Updating Sound Device Drivers. The best audio drivers to have are usually the latest ones for your computer model supplied on the web site of your computer manufacturer, assuming you have a branded computer like Dell or HP.

If stereo mix won’t work, I suggest you do what it says on and use Windows WASAPI host to record. This allows you to record the web from other than the built-in audio device.

  1. Open Device Toolbar .
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Playback device) box in Device Toolbar, choose the Speakers or Headphones that you are using for listening.
  4. In the third (Recording device) box in Device Toolbar, choose the (loopback) input for the same device you chose in step 3. For example, if you chose “Speakers” in Step 3, choose “Speakers (loopback)” in this step.
  5. In the fourth (Recording Channels) box in Device Toolbar, choose mono or stereo.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.


Sorry, I was unable to get back here sooner.

Yes, I had the input slider turned up, and was recording using “Speakers (Realtek HD)”. So last night I thought that before changing settings I’d do a reinstall to see if that made any difference. It did the trick; recording is working again now. I don’t know what was wrong, but I guess something got corrupted. At any rate, I’m back to being a happy camper. Thanks for your time and expertise. Hopefully this thread will help someone else if they have the same issue.

I’m glad it was fixed, so I’ll mark the topic [SOLVED] and lock it.

I’ll add that unless you chose the option to “Reset Preferences” in the Audacity installer, reinstalling would not actually change Audacity settings.