Audacity frozen after ending recording, stuck in limbo

After I was done recording, I went to stop recording, and Audacity has frozen. I’m not sure if it’s saved any of the files or taken a snapshot as it’s still stuck “stopping” my recording, so I’m worried that restarting the application may still lose the file (and I can’t seem to find where the temporary files might be to confirm). I’ve tried closing other applications to free up some memory but the application still seems to not be responding.

For context, I’m running OS 12.2.1 and I think I’m running Audacity 3.1.3.

I’ve also attached a screenshot for reference.
Audacity Screenshot - July 12.png

How did you launch Audacity? I see that the Audacity “.dmg” image is still mounted - did you complete the installation or did you launch Audacity directly from the mounted DMG?
If you are not sure, see the installation instructions here:

If Audacity was fully installed and correctly launched, the the temporary data (the unsaved project) will be in:
/Users//Library/Application Support/SessionData

If Audacity was launched from the DMG, I’m not sure what happens. Some files that Audacity requires will not be available, so Audacity will not be fully functional.

Hello, thank you! I’m pretty sure I launched it from the application (the DMG itself was already in my “Trash” bin though I hadn’t emptied it yet). I tried checking the folder you suggested but it doesn’t seem to have anything in it. I don’t know if it makes a difference but I still haven’t closed the application in hopes that my file can be salvaged. It still looks the way the screenshot showed, plus pinwheel of death when moused over.

You get the pinwheel of death when the Mac takes longer to do something than the time allowed. I don’t know of any way to “unfreeze” a Mac when an application stops like that.

What was the show? What were you recording? How long was it?

What other apps did you have running? Do you have iCloud or other web-bases apps? Audacity doesn’t much like using iCloud. It can be unstable.

Audacity can take up a lot of room in memory when it’s running. It’s not a good idea to group a lot of apps in the background with Audacity.

It may be worse than you think. Your Mac may not want to shut down with Audacity stuck like that. Do you know how to emergency power off?

Press and hold the power button for a long time. The Mac will power down and stay there. When you power up, wait for the Mac to settle (go make coffee) and then Apple > Shutdown the regular way. Start. It may take a while to clean up after itself. Then, when you start the second time, it should be healthy again.


Oh my gosh. I had no idea it could get this serious. I guess I’ll just venture to try shutting it down, hope for the best, and restart it.

The show was just my track of audio for a podcast, a little over an hour. I unfortunately had quite a few Chrome tabs running in the background, which may have been the problem. I don’t have iCloud running, but a good flag that if I do, to turn it off.

Well, good news: I decided to suck it up and try restarting it, and the files, thankfully, are there.

Thank you, @steve and @kozikowski very much, though, for responding and helping me through this.