Audacity Freezing When Importing MP3

Windows 7 / 2.1.2 / .exe

I’m a little bit new when it comes to audacity. I’ve been trying to open an mp3 file but the program freezes when it says “elapsed time 00:00:01/Remaining time 00:00:00”. Nothing happens no matter how long I wait. I’ve tried opening other files and it works fine and I’ve tried opening the same file on another computer but I still have the same problem. Can anyone help?

How do you know it’s an MP3 file? Windows likes to hide the full filename and this is one time that’s not a good idea.

Reveal Filesname Extensions.

Displaying the File Extension in Windows Vista and Windows 7

Click the Start menu. …
Type “folder options” (without the quotes). …
A dialog box with the title “Folder Options” will appear. …
Click to uncheck the box for “Hide extensions for known file types”.
Click the “OK” button at the bottom of the dialog box.

It’s a good bet the file is not .mp3.

You can get Audacity to open a lot of different file types by adding the FFmpeg software. Scroll down on this page.


I am pretty sure it is an mp3. The properties say that it is an MP3 Format Sound (.mp3).
I also tried adding the FFmpeg software but nothing has changed.

The gold standard is still to force Windows to show you the official filename.

It’s possible the file is corrupted or someone made a file with the incorrect extension. Many times INFO services just look at the extension (you can’t see) and just assume it’s correct. That can lead you to chase your tail.

If it won’t play anywhere else, it may be just broken.


Does the file play on your computer? (With Windows Media Player, etc.?)

If you know the playing time, a good-quality music MP3 (or other compressed audio file) will be about 1MB - 3MB per minute. (A lower-quality more- compressed file could be smaller, but if it’s 1/10th that size it may not be an audio file.)

You can check the file with [u]MediaInfo[/u]. If it’s an MP3, MediaInfo will say “MPEG (Version 1) (Layer 3)”… plus a bunch of other information.

[u]TAudioConverter[/u] can convert between many different file formats, so you can try converting to WAV or FLAC, and then open the new file in Audacity for editing. Don’t convert it to a new MP3 file if you want to edit it because Audacity is going to decompress the MP3 anyway and you should minimize the number of generations of lossy MP3 compression.

I downloaded a free trail for a different audio editing software and it works fine there. It seems strange that it won’t work in Audacity.

The file is definitely an mp3. I have checked it multiple ways now.
Thank you for suggesting TAudioConverter, DVDdoug. I converted the file into WAV and now I can open it in Audacity!

We must always warn though to get the MediaInfo version without installer, because the installer may have malware or adware.


If you get another MP3 file that behaves like that, please attach it (if 2 MB or less) or upload it somewhere we can download it from. That way we can test it out and see if there is any action we can take.

Note that adding FFmpeg won’t help in itself if Audacity’s MP3 importer is taking the file automatically and choking on it. You also have to use File > Import > Audio… or File > Open… then choose “FFmpeg-compatible files” in the “Files of type” box to make FFmpeg take the file. And due to a bug, you may have to open and OK Preferences first to make sure that FFmpeg takes the file.



Hi all together.

I only registered here to send my own experience concerning this problem.
I had the same freeze of audacity when i wanted to import audio files.
There was a problem with the temp folder. My user account had no right to write into the specified directory.
I had to chose another:
Open ‘Edit’ → ‘Preferences’.
Chose ‘Directories’ on the left menu.
Press ‘choose’ on the right.
Select a directory where audacity can save the temporary data. The directory ‘SessionData’ will be created if it is not existing.
If this will fail e.g. due to missing rights, audacity will tell you. Then choose another place.

Hope it will help the one or the other having this problem.

Have a nice time with audacity and thank you for reading.