Audacity freezing on drag import/error when importing from menu

Hello, I’m new to these forums, mainly because I never really needed them before.

The issue’s in the title, when I try to import something, in this case an MP3 fire, into Audacity dragging it in, it freezes. I have to use Task Manager to close it. If I import using the File menu, I get a window for debug reports. I’ve looked at a tutorial for fixing this about FFmpeg library being missing, but it keeps crashing. This is the most recent log.

03:19:01: Audacity 3.0.2
03:19:01: Trying to load FFmpeg libraries...
03:19:01: mLibAVFormatPath ('C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll') is not empty. Loading from it.
03:19:01: Looking up PATH environment variable...
03:19:01: PATH = 'C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR;C:\Users\purpl\AppData\Local\Programs\Python\Python38\Scripts\;C:\Users\purpl\AppData\Local\Programs\Python\Python38\;C:\Users\purpl\AppData\Local\Microsoft\WindowsApps;'
03:19:01: Temporarily prepending ';C:\Program Files (x86)\FFmpeg for Audacity' to PATH...
03:19:01: Checking for monolithic avformat from 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
03:19:01: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: The specified procedure could not be found.)
03:19:01: Error: Couldn't find symbol 'avcodec_version' in a dynamic library (error 127: The specified procedure could not be found.)
03:19:01: avformat not monolithic
03:19:01: Loading avutil from 'avutil-52.dll'.
03:19:01: Loading avcodec from 'avcodec-55.dll'.
03:19:01: Loading avformat from 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
03:19:01: Actual avutil path C:\Program Files (x86)\FFmpeg for Audacity\avutil-52.dll
03:19:01: Actual avcodec path C:\Program Files (x86)\FFmpeg for Audacity\avcodec-55.dll
03:19:01: Actual avformat path C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll
03:19:01: Importing symbols...
03:19:01: All symbols loaded successfully. Initializing the library.
03:19:01: Retrieving FFmpeg library version numbers:
03:19:01:    AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
03:19:01:    AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
03:19:01:    AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
03:19:01: Returning PATH to previous setting: C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR;C:\Users\purpl\AppData\Local\Programs\Python\Python38\Scripts\;C:\Users\purpl\AppData\Local\Programs\Python\Python38\;C:\Users\purpl\AppData\Local\Microsoft\WindowsApps;
03:19:01: FFmpeg libraries loaded successfully.
03:19:09: File name is C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\mods\3DS Jukebox - Hypno\sound\project\music\02 Title.mp3
03:19:09: Mime type is *
03:19:09: Opening with libmad
03:19:09: Open(C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\mods\3DS Jukebox - Hypno\sound\project\music\02 Title.mp3) succeeded

Though, I feel the need to mention two things.
I’ve tried to use different audio editing software, but the same thing happened there. One would import, but only play the first second repeatedly.
The only things that can be imported normally are OGG files. This wasn’t the case before.

This line

03:19:01: FFmpeg libraries loaded successfully.

shows that FFmpeg is loaded correctly. (FFmpeg is not the problem).

This line is probably showing the cause of the problem:

C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\mods\3DS Jukebox - Hypno\sound\project\music\02 Title.mp3

The folder “C:\Program Files (x86)” should never be used for user data. That folder is intended for applications.
Ensure that you MP3 files are in your “userspace” (such as “Documents”, “Music”, “Desktop”…)

Nope, still the same thing.
I don’t think that’s the thing, as you can guess, this is for modding a game. I’ve made many mods for it, some involving custom sounds, always having them in Program Files (x86) and I’ve always drag the files to Audacity just fine before.
I’ve had time to think and remember that the last time Audacity worked properly was me importing an OGG file that had multiple tracks in it. Not sure if I’m even describing that right.

I CAN open an MP3 from Program Files (x86) but I can’t export there. I have to save/export somewhere else and then copy/move it.

Check the file with [u]MediaInfoOnline[/u]. If it’s really an MP3 it should say MPEG Audio, Version 1, Layer 3. It will also give you some information about the bitrate and playing time, which can sometimes be useful. It won’t always tell you if you have a defective or non-compliant MP3.

Another thing you can try is converting the file to WAV with TAudioConverter or Kabuu Audio Converter. Some programs are more tolerant of imperfect MP3s. (You’ll probably have to save the WAV somewhere else.) Then you can open the WAV in Audacity and re-export as MP3 (or whatever format you want) when you’re done editing it.

There is also a program called [u]MP3diags[/u] which can diagnose, and often repair, MP3s.

It’s all there, MPEG Audio, Version 1, Layer 3. I even ran the file with a music player, works just fine. But now I remember that I ran the OGG with a music player too, it had an error after a certain point. It was around 10 minutes, crashed before the 3 minute mark. That’s why I put it in Audacity and saw that it had multiple 2 minuteish tracks.

Should I upload this OGG file I keep mentioning?