Audacity freezes every time I attempt to zoom in with touchpad

Hello, I was using Audacity when I tried to zoom in using the touchpad on my laptop, and suddenly, everything froze. The cursor moves, but it doesn’t do anything in Audacity when I click on it, and I need to force quit using Task Manager to quit it. I tried force quitting multiple times, using older versions, but nothing seems to work. Is my project cursed? What can I do to solve this?

Now I realize I can’t export either. Augh.

I forgot to state that I am on Windows 10, and I’ve attempted to use 3.1.3, 3.1.2, and 3.1.0, as well as even 2.4.2, but none of them work.

I’ve posted a thread on this topic before, but I believe it got no response because I posted again in the same thread, so I am posting again. Audacity has been freezing on me every time I attempt to zoom in with the touchpad on my laptop (but strangely not when zooming in using the zoom button) and when exporting. No error message, no anything, Audacity just refuses to work and doesn’t respond. I’m on Windows 10, and I’ve attempted to use Audacity 3.1.3, 3.1.2, and 3.1.0, as well as even 2.4.2, but none of them work, all have the same issue. I tried restarting with a new project, same issue. Nothing seems to work.

I suspect that you got no response previously because no-one knows the answer. The problems that you are describing are not known problems.

Do you still have the same problems if you use a mouse rather than the touchpad?
(Personally I never use the touchpad with Audacity because it is too inaccurate. I find that a mouse is much better with Audacity).

Have you tried “Tools menu > Reset Configuration”? If not, try that.

Sorry for the late response. I thought I solved it, but the issue arose again. No, it doesn’t seem to work.

FWIW, I have laptop with both a touchscreen and a touchpad. I use neither as I find a wireless mouse more accurate and much more convenient. I just tried to reproduce your issue with my touchpad and also with my touchscreen. I could not get Audacity to hang even after zooming all the way in to the sample level then out again. (Although sometimes my zoom commands were ignored - but I attribute that to my clumsiness, and repeating my zoom motions worked OK. :smiley: )

I have the same issue

We noted on the video forums that New Users might have troubles because video (and audio) are the first times the machine had to use large portions of memory and drive. Everybody was fine composing emails and creating spreadsheets, but entertainment production is a different animal.

I would start doing machine analysis. There was a program called Memcheck which would fill up the machine’s memory and then empty it out and check for deletions, damage, or explosions. I had a version which would loop several times, and yes, I did discover bad memory.

Same with the drive. There are programs which can do drive analysis. Make fresh coffee. They’re not fast.

How old is the machine? I have one machine in a non-critical support job because the track pad doesn’t work right. They do get old and break.


Quick note. Drive analysis programs are not recommended on solid state drives. They usually tell you that.