Audacity freezes at startup and its logo remains frozen in the screen

Audacity freezes at startup and its logo remains frozen in the screen.

It is impossible to exit Audacity without forcing the computer to restart.

My laptop is an HP Pavilion dv6 (i5 with 8GB ram).

The system is Linux Mint Mate 19.2 64 bit.

The version of Audacity is that I installed from the PPA.

Initially I had installed the version of the repository that I believe was 2.2.1, but since it didn’t work, I uninstalled it and started deleting the".audacity-data" directory before installing the PPA of the recent version.

I found mention of this problem on your site and when searching by Google… but never any solution declared.

I have another old desktop computer (Duo and 8GB ram) that also runs on the same system (Linux Mint Mate 19.2 64 bit) but, unlike it, Audicity loads without any problem.

Is there anything I can do to fix this problem or should I just wait for a compatible version of Audacity?

In what way did 2.2.1 not work?

Please note that most PPA’s offer no user support, so I would not generally recommend using them.

I’m not sure if my memory is good, but it seems to me that the version of the repository was 2.2.1

My memory is that it didn’t start at all either.

The PPA I used is the one ( suggested in the installation instructions for the Audacity website (

I made a mistake in my first text, it is obviously version 2.3.3 (rather than which is now installed.

Curious, I had answered earlier, but the message didn’t appear.

At the launch of 2.2.1, nothing was happening.

The PPA is the one recommended in the Audacity site instruction.

If you try launching Audacity from a Terminal window, the messages in the Terminal may give some indication of where Audacity is getting stuck.
To launch Audacity from a Terminal window, open the Terminal and enter:


Okay, I launched Audacity through the terminal. He froze on his logo like the other times.

Here is what was written in the terminal:

:~$ audacity

(Audacity:1867): Gtk-WARNING **: 23:48:11.188: gtk_disable_setlocale() must be called before gtk_init()

Open you file browser in your Home directory and enable “show hidden files”.
Find the folders:


and delete them.

Then try launching Audacity 2.2.1.

The installed version is not Audacity 2.2.1, it is rather Audacity 2.3.3

I deleted ~/.audacity-data
But ~/.audacity-files didn’t exist in my home
(maybe because Audacity has never been able to open completely and thus create any files.

This did not work (even after a reboot), Audacity still remains blocked at startup on the display of its splash screen logo.

There doesn’t seem to be a solution…

I mentioned earlier that the terminal sent me the following message when trying to open the software (which freezes systemmatically on the “Audacity” logo):

(Audacity:1867): Gtk-WARNING **: 23:48:11.188: gtk_disable_setlocale() must be called before gtk_init()

I don’t understand what the terminal wants me to do, but is it possible that the problem is identified there?

That’s not an “error”, just a “warning”, which I believe is due to different requirements for initializing locale on different platforms. I also see those warnings without any problem.

I recommended using Audacity 2.2.1 from the main Ubuntu repository because I know that version works (I use it), whereas PPA builds are largely untested.

Before installing 2.3.3 from the recommended PPA, I had the same difficulties with version 2.2.1 which in Linux Mint Mate 19.2 comes from the Ubuntu repository. No differences…

I indicate another discussion I found on the forum that seems to have described the same problem. It also ends without any indicated solutions:

From day 1? Has Audacity ever run on this machine?

No, I have never managed to get Audacity to open correctly (without freezing at its logo level) on this machine since I reinstalled it with Linux Mint Mate 19.2 64bit. This is true for both Audacity version 2.2.1 (repository) and 2.3.3 (PPA).

Audacity is the only software that freezes on this machine, a laptop that also works very well with all the other software I am used to installing.

Previously this computer was running under version 18.3 of Linux Mint Mate 64bit. Audacity was installed and working very well. I did a complete re-installation, first with Linux Mint Mate 19.1 64bit, then I updated it to 19.2. It was at this step that I then tried to install Audacity.

I also have 2 other computers that work well with Audacity 2.3.3; one under Linux Mint Mate 18.3 64bit and the other under Linux Mint Mate 19.2 64bit.

I have been using Audacity for a very long time and have successfully installed it on many different computers and Linux versions.

This is the first time I have been confronted with an impossibility to make Audacity work.

Does “Gnome Sound Recorder” work on that machine?

I’m also on Linux Mint 19.2 and I had the same problem after a kernel update.
I’m using Audacity 2.2.1.

I’m guessing that you upgraded to 19.2 around the time the bad kernels emerged.
(By ‘bad’, I mean there’s some incompatibility with Audacity.)

For me, the newest kernel that still works with Audacity and doesn’t cause the freeze at launch is 4.15.0-55.

I tried a few in 4.15.0-6x and the latest 4.15.0-72 and they all cause this same crash.

I suggest installing 4.15.0-55 or earlier (-48 also worked fine), and choosing the older kernel on bootup in grub to see if that solves the problem.

(I’m still using -55 just to have a way of using Audacity. For me, everything else works with the newer kernels.)

Good luck!

I’m using “5.0.0-36-generic” in Ubuntu, and it works fine for me.

“Gnome Sound Recorder” is not installed by default on Linux Mint 19.2
I installed “Audio-Recorder” instead, and it works very well.

I followed your advice, I reinstalled 4.15.0-55 and then booted on it, unfortunately Audacity doesn’t work any better with this kernel…

I’m afraid something was corrupted during my first unsuccessful installation of Audacity (2.2.1) and that this flaw now blocks the operation of any version of Audacity I install, fortunately, without affecting the rest of the system and other applications.

Maybe a reinstallation of my entire system would be the best solution to fix this, but it would be too much work to reinstall, optimize and reconfigure all the software I add. So… I’m afraid I’ll have to do without Audacity on this machine, until I have no choice but to reinstall a new version of Linux Mint in a few years.

Has anyone found a solution for this? I’ve had this issue since doing a fresh install of Mint xfce 19.3 in December 2019. The problem exists with the latest Mint repository version and with the latest Audacity version 2.3.3

I note that Audacity runs perfectly on MX-Linux vers 19.1, on the same machine.

It looks like a dependency issue. Any suggestions would be very welcome.

As this problem appears to be specific to Linux Mint 19.x, has it been reported to Mint?

Yes, in December 2019, and reactivated today.