"Audacity failed to read file on drive c:"

Windows 10
Audacity 2.2.2

Part 1:
Working on a project for over a month (Podcast series). I have exported to mp3 many ‘rough cuts’ to listen to and fix up. I’m finally at the ‘ready’ stage and blammo… this error pops up when trying to export to a) my desktop b) Documents/Audacity and even c) Entirely different drive and location.

Part 2:
A little frustrated, I decided to surf the web for solutions. While doing this I also load up a different episode to begin the process of editing. I get a noise profile, then try and start the noise reduction process… a few seconds go by and blammo again. Now I can’t edit the files?

Part 3:
I read that it may have to do with Win10 ‘permissions’ and so I’ve tried two different solutions to that and I’ve gotten no luck (1 involved editing the security tab under a folders properties menu and making sure the user was flagged as able to edit files, the other involved disabling the LUA via registry).

The problem persists and is extremely irritating.

I can see several error messages similar to that in the code, each warning of a different error condition, but I don’t see that exact message.
Please check the exact wording of the message so that I can look up what error condition it is referring to.

“Audacity failed to read from a file on drive c:”

Are you using punctuation marks in your filenames? Dates, for example?

If you select your filenames wrong, you can force the machine to look for directories that don’t exist.

Upper, Lower, Numbers, -dash- and underscore are the only unconditionally safe characters. Your machine may allow others, but you may fall in the mud if you need to share files with somebody else.


With an element of randomness creeping in to these problems I would be inclined to check that you are not running out of disk space. Audacity needs temporary file space as well as storage for saved projects and exported files. If there is apparently plenty of space left then try using check for errors which you will find if you open the properties for the C drive then choose the tools tab. Because its the system drive the computer will reboot in order to check the drive.

I’ve found the relevant bit of code that produces this error message, but unfortunately it does not tell us much that we don’t already know.

The most likely trigger for the error message is that Audacity is unable to read the audio data that belongs with the project. There can be many reasons for that, such as an external drive not being on-line or at a different address, or the project being created in a different user account so that the current user (hence Audacity) does not have sufficient privileges to access the data.

Where are the project files (including the audio data) located?

File name is ‘DATT Episode One’
File has been exported previously onto desktop as an mp3, in the last week Audacity decided it’s got a problem
File is on drive C: (Desktop), Drive c: (Documents/Audacity) and Drive E:
Drive C has 33 gb of space, drive E has 128 gb of space
Computer is my personal pc, no other users

Neither drive generatees error messages when drive is checked for errors

This is where you start being obsessive about what you write.

File is on drive C: (Desktop), Drive c: (Documents/Audacity) and Drive E:

That’s impossible. An Audacity project manager (AUP) and the work files (_DATA) of the same name have to be in the same place or folder and on the same drive.

There is no c:\ and e:\

Where did d:\ go? Windows likes to number the drives in sequence and last time I did this, it will try to put the hard drives in order and push optical drives further up as you add stuff.


on desktop: Folder ‘PODCAST’ - inside, Audacity file(s) plus it’s folder(s)
On c: it’s under ‘Documents/Audacity’ with APF file(s) and folder(s)
On E: it’s under DATT Backup folder, contains APF file(s) and folder(s)

NONE of these apf files in ANY of these locations will let me export to mp3 or run the recording(s) through effects like noise reduction. This is a NEW thing (within the last week or so) and previously I could export and edit with no problem.

Apparently I CAN start, record and edit new projects. So unless it’s tied to length of project (30m - 1.5 hr), it doesn’t appear to be a bug within Aud 2.2.2 itself. Next step I’m going to try is to copy/paste the effected project files onto a new project and see if that is a work around.

Next step I’m going to try is to copy/paste the effected project files onto a new project and see if that is a work around.

The project name is burned into the AUP file. So if you do that, you may need to create a fresh project in a folder so the two Projects don’t interfere with each other—and use the same name.

A Project used to be limited to 13 hours, but I think that restriction has been lifted.

What happened to the d:\ drive again?


importing to new project in new folder didn’t work.

Drive D: is my blu ray… typical windows protocol for the last 25+ years is drive D: is your cd/dvd/blu ray device.

typical windows protocol for the last 25+ years is drive D: is your cd/dvd/blu ray device.

Except on my machines where C:\ and D:\ are two hard drives and E:\ is the optical drive.

I don’t think we’re any closer to finding out what happened to your work. The errors don’t fall into any common patterns, and nothing stands out as being unusual or out of place.

While we have a terrific track record for solving problems, it’s not 100%.


I can only reiterate that you should run integrity checks on your C drive immediately. Hard drives are by far the most common cause of failure and its far better to catch any problems before they become terminal. Also it only takes one unexpected power failure to corrupt the disk contents and the windows checking utility will put this right.

I’ve now ran 3 disk scans on all drives, last was chkdsk /f.
No errors on drives detected.

Tried running Audacity under right click ‘run as administrator’ and then exporting to mp3… no dice.

At a loss at this point.

Perhaps you could upload the project somewhere (such as dropbox or sendspace) so that we can check it.
The easiest way to upload the entire project is to create a ZIP file containing both the project’s “AUP” file and its “_data” folder, then upload the ZIP file somewhere.
(There’s an article here about how to make a ZIP file on Windows 10: https://www.cedarville.edu/help/Windows-Zip-Compress-Multiple-Files)

And playing the forum card for a minute: if you do sort it out, post how you did it. A terrific number of our solutions are personal experiences or reports of outside solutions, not only notes from the Program Development Division.


Well that’s good news. The next thing to suggest is that you may have inadvertently hits some file size limits of various kinds. Firstly confirm that you c: drive is formatted as NTFS, that will more or less eliminate any system limits on size or path name lengths. Then browse through all the data files in the project and look for anything that hits 4 GigaBytes or more. If there are any list them here and let the Audacity experts tell you whether there are any format limits for them.


i am dealing with this right now as well. pretty much all the same stuff – i can’t apply effects or export audio, though about a week ago i was able to. saved to my C: on windows 10, plenty o’ space, i can play the audio but exporting and effecting don’t work, etc. etc. etc. these are the two messages i get, first one is when i try to export, second is when i try to add effects:
audacity error 2.JPG
audacity error.JPG

Did you check to see if “C:\Users\Wasabi\Documents\Audacity\tape 1.wav” exists?
Does it exist?

I’m having the same problem :cry: