Audacity failed to read a file in C:

Good afternoon. After recording a file in Audacity, I am unable to export it as an MP3. The error message reads: Audacity failed to read a file in C:. The history of the file is as follows. I initially recorded the file in Audacity on another laptop and uploaded it to Librivox. A few days later, I saved it (and 9 others) on a thumbdrive and saved it (and the others) on this (new) laptop. I uploaded the file to Librivox and must now make one small edit. I did so in Audacity and resaved the file in Audacity. Upon attempting to export it, I generated the error message. I have tried a number of fixes, including saving the file elsewhere on the laptop, but no matter where it is saved, I am unable to export it. I would rather not re-record it, particularly without knowing for sure that the new version will upload successfully, if that can be avoided. The file is about 27 minutes and 30 minutes long. I am running Audacity 2.4.2 on a brand-new Dell Inspiron 14 7000.

Thanks much for any help you can provide.


You mean that you re-saved the project, or you re-exported an audio file? Where did you save or export it to, back to the thumb drive or to somewhere on your computer?

Avoid working on thumb drives. They can be useful for storing / transferring files, but they tend to be less reliable than a hard drive / SSD when working with open files.

Steve, I opened the file in Audacity on Computer 1 and re-saved (not export) it to the thumb drive. I then moved the thumb drive to Computer 2, opened the file on the thumb drive and re-saved (not export) it in Audacity to Computer 2. Later, I opened the file in Audacity on Computer 2, made one change, and again saved it in Audacity on Computer 2. I can open the file in Audacity on Computer 2 but cannot export from Computer 2 to an MP3, to be able to upload it to Librivox.

I appreciate the advice about avoiding thumb drives, which I follow religiously. I never worked on the file while on the thumb drive and used the thumb drive only as a way of transferring the file from one computer to another–the only practical way of doing so because Computer 2 does not have Outlook installed.

Incidentally, Computer 1 runs version 2.3.3, and Computer 2 is running version 2.4.2, even though the two versions were installed only weeks apart. Could that have something to do with it? Just wondering.

Thanks for your help,


The way I would recommend doing that:

  1. Create a new, empty folder on Computer 1.
  2. Save the project into the empty folder.
  3. Copy the entire folder (containing the project) from Computer 1 to the thumb drive.
  4. Safely remove the thumb drive from Computer 1.
  5. Plug the thumb drive into computer 2.
  6. Copy the folder from the thumb drive onto Computer 2.

I assume that you are referring to the “project”.
When opened in Audacity (on computer 2), can you play the project all the way through?
If so, can you Export as a WAV file?

I’ll give all this a try. Thanks much.

Yes to all:

  • Eject or unmount and then remove thumb drives. Don’t just yank them out. How you do this changes with the machine.

  • Make sure any transfer, copy, or move is completed before you manage drives.

  • Don’t use punctuation marks in filenames. Upper case, lower case, numbers, underscore, and -dash- only. No slashmarks. Today is 2020-07-29.

I know I’m dooming myself, but I use thumb drives all the time and I’ve never lost or damaged a file.

If your machine is old enough, you can have ratty USB terminals. I don’t directly use USB connections. I install easily replaceable, short USB jumpers and wear those out.


I have found a relatively workaround! I cannot follow all the code and syntac fixes that were offered.

But I spent 3 hours working on an editing project and then I went to save it and got that “Audacity failed to read a file in C:” error message.

I tried downloading around 6 different older versions of Audacity, but to no avail. Then, I could not load up my project file anymore…that was annoying. Then I change the extension from “.aup” to “.aup3” and I was able to load the project, BUT not save it, because of the “Audacity failed to read a file in C:” error message.

So, the work around was to open a new blank Audacity file and copy and paste sections of the project. What I discovered was there was a small section in the audio track recording (only 10 seconds), which I could not copy and paste, due to the “Audacity failed to read a file in C:” error message. So, I was able to copy and paste my entire project (minus 10 second), into a new audio file and then save it via MP3 route…problem solved.

Of course, I took the original recording to grab the missing 10 seconds I needed.

I hope this helps. I use a Windows personal PC by the way.

Note that the post your are replying to is 1.5 years old and refers to an older version of Audacity.

This is a duplicate post. Please see the reply to your other post here:

I have locked this thread to avoid future confusion.