Audacity E-MU1212m Problem

I’m running Windows 8.1 & have the E-MU1212m & Patchmix DSP software hooked up to a Behringer 1622fx. It has be running fine with Cool Edit 2000 & Audacity 2.0.6 with 2gb 240pin dimm PC3-10666 1333 memory but since I added 2 - 4 gb sticks totaling 8gb when I record from my stereo I can’t get it to work & when I do it stutters. If I pull a stick out I can get it to always record be the playback strutters. I can set it to loopback & it will record fine from audio that’s on my computer. It also records fine if I use the old 2gb stick of memory. I’m guess Cool Edit 2000 has a problem with anything over 2gb & Audacity well IDK. Any help would be appreciated!

PLEASE don’t tell me to search I read EVERY thread on this & nothing helped. The ONLY thing I don’t have is the chipset drivers from Asus for my Ma477t/usb3 motherboard. I’m waiting for them to upload the correct ones. I was told in 2 to 3 days they should be up.

It doesn’t sound like the problem is confined to Audacity then.

Please say what version of Windows you are using.

You have to be careful when you add memory that the new memory is compatible with the old. See here for how to test memory (ignore the first section “Microsoft’s Windows Memory Diagnostic” because that only tests the first 4 GB of memory).

If you are saying that WASAPI host works for you in Audacity then you can try Audacity 2.1.1 from - in 2.1.1 you can use WASAPI for physical inputs.

Otherwise follow the obvious procedures of starting with 44100 Hz project rate in Audacity and using the same rate in Windows and in all other software and hardware settings.

If you have not yet done so you can contact Creative support through this page:,VARSET=CategoryID:237.


I’m running Windows 8.1 64bit Asus M4a77t/usbs3, AMD Phenom II X4 955 cpu 3.20 quad core. There’s a Dram button on my MB & it said memory suceeded. I don’t see any weird things happening. I contacted PNY Crucial & a couple local computer shops & Asus & they said they think it’s the program. I did read that sound recorder had problems with memory over 2gb so I was thinking that was the problem with Cool Edit 2000 since it’s from 1999. The E-MU Dsp patchmix is set the same way it always was. I tried Audacity 2.1.1 & it did the same thing.

This guy is having the same problem as me.

I was ready to send this memory back but Crucial looked up the memory & said they would give me something just about the same. Also my MB doesn’t support more then 4gb sticks but it tried an 8gb PC3-12800 & the memory post ran at 1600 with the same problem. Weird thing is if the sound is on the computer loopback works & it records fine but Cool Edit doesn’t work at all. And as soon as I try to record from an outside source it records silent & then after some different configurations which I can’t reproduce now it did the same as the video above.

I did run Memtest86 & no errors were found.

Nevermind I fixed it. Turns out I check under Device Manger & sound & since I upgraded my video card Nvidia was some how interrupting things I disabled Nvvidia & now I can use MME in Audacity.

Thanks for following up. Feel free to add to the topic if something changes.


Well I guess I spoke to soon :frowning: I rewrote my virgin image to update & make a new image of my system only to find when I disabled those things it does not work again. Any help would be appreciated.

I’m absolutely positive it’s my new memory. My old stuff is PC3-10600 1333 & the new stuff is PC3-10666 my CPU is an AMD Phenom II X4 955. As soon as I put the old 2gb stick in I can use Cool Edit 2000 & Audacity 2.0.6 & 2.1.1 on MME.

By which you mean you don’t get garbled playback and recording in Audacity using MME?

Did you try WASAPI in 2.1.1 or do you need MME? Bear in mind that if you want to use MME you should set “Default Format” for all the EMU inputs and outputs in Windows Sound to the same rate as Audacity project rate. Otherwise you may get garbled results irrespective of memory issues.

I don’t think Audacity has a problem with more than 2 GB memory. I have 6 GB memory on Windows and I added another 2 GB memory for a total of 4 GB on Mac. On Windows, a 32-bit app like CoolEdit or Audacity can’t address more than 2 GB RAM because Windows does not allow it, unless the app respects 4GT tuning by enabling IMAGE_FILE_LARGE_ADDRESS_AWARE and you’ve turned 4 GT on. Audacity does not have IMAGE_FILE_LARGE_ADDRESS_AWARE enabled.

Of course, your sound card may be sensitive to extra RAM or even slightly mismatched RAM. I think you would have to discuss this with Creative, Crucial or on more technical Windows forums that are concerned with tuning and overclocking.


Correct I don’t get garbled playback with the 2gb module & MME works.

I did try WASAPI in 2.1.1 with the 2-4gb memory modules & is the only way it works with my Behringer 1622fx on channel 7/8 & will record correctly with everything on my computer or internet. But with WASAPI & my Behringer 1622fx on channel 1 (Mic) or 5/6 (Stereo) it records silence & sometimes (I don’t know how) it records but it records garbled & sometimes it records fine but most of the time it records silence or the line that shows what’s being recorded just stays at the beginning jumping slightly. Cool Edit 2000 never records anything with the 2-4gb modules it only records silence & the peak meters are steady about 1/4 of the way up acting like it doesn’t hear sound. I am using “Default” with Patchmix DSP. If I take 1-4gb module out most of the time it records fine on all channels but does get the above problems. The 2gb module works correctly with everything & so does Cool Edit 2000. I’ve flashed my BIOS to the newest version. I’ve can’t find the motherboard drivers for Windows 8.1 64 bit OS. I’ve ran Memtest86 8 passes & no errors. I’ve tried clearing CMOS. I’ve tried different configurations with the 2-4gb modules in the DIMM slots pressing the DRAM button each time. The problem comes in when I add that second module. I’ve tried Reaper & it only works with the ASIO setup.

So I ordered memory from Crucial that they said would work & assured me they could get to work. NOT!

ASUS told me it’s the latency. I believe them because the PNY had a 10ms & I could record sound already on computer & playback was fine but with the Crucial CT7348776 it breaks up & the latency is 11ms. On my old Crucial 2gb stick it’s 4ms & the new memory is 11ms. Crucial has no idea how to correct the latency in Audacity or Cool Edit 2000. I can only record silence & breakup sound with the new faster memory. So does anyone know how to make Audacity work with the new memory?

It records fine with the old 2gb Crucial memory but with the new memory I get the same problem as with the PNY.

System Specs:

Windows 8.1 64bit

ASUS M4A77T/USB3 motherboard newest BIOS 0801

Newest AMD motherboard Chipset drivers

CPU AMD Phenom II X4 955

Soundcard E-MU1212m newest drivers & newest Patchmix all set & working

What is the PNY?

Audacity has a setting “Audio to buffer” in Recording Preferences. If E-MU has a buffer setting for example in its control panel, you may need to adjust that setting as well.

Sample rates are important too. Excessive sample rates or rates mismatched between the device, Windows and Audacity can and do cause garbled playback (or speed problems). If using MME host (which is high latency), Default Format in Windows Sound must be set to the same rate as Audacity.

If using lower latency WASAPI, you should be better to turn on Exclusive Mode in Windows Sound. Then the Default Format rate should be ignored. You still have to set the same rate in E-MU, if it can set sample rates.


PNY is the other company that I bought memory from. 8GB PC3-12800 & PC3-10666 1333

I did mess with with those settings in Audacity & E-MU does have sample rates which I tried different ones setting both to the same rate but still won’t let it record nothing but silence & sometimes stutter. I’m not sure what the E-MU bit rate is but in Windows 8.1 sound it shows 48000 24 bit & I can not change it. I have all windows sounds off. Once in awhile it will record sound from wave or my stereo/mic & sometimes it records fine & other time it’s broken up in precise moments like something is interrupting it.

I tried Cool Edit 2000 & Wavepad with the same results. Wavepad reports it doesn’t hear sound & asks to configure it. I know my Patchmix DSP software is set right because it records with the 2GB DDR3. I even tried Cubase LE using the E-MU ASIO driver & all recording programs act like they don’t hear sound with more then 2GB ram.

During my research last night I found others that have the same problem here:

It seems to be that the E-MU sound card has a problem with anything over 3GB ram. I don’t know if it’s the drivers Patchmix the 4 cores in the CPU or what? But no matter what config I use I get the same results silence on recording with no peak meters bouncing in any recording software. I thought maybe if I bought PC3-10600 1333 memory it would work but I really doubt that will fix the problem after reading the above threads. Although they did say a lot of people are having success on a 64bit system using 8GBram recording with no problems. But no one is commenting. I guess the thread is too old.

I contacted E-MU & they pointed me to another old thread which was useless. Crucial ASUS & a few computer shops all said if the memory posts it should work & my problem is strange & they never heard of such a thing.

I paid $200 for the sound card it’s the PCI version & really don’t want to buy another one but I don’t want to be stuck with only 2GB ram when running a 64 bit system.

I noticed others have tried disabling sound from their windows & graphics card & messed with turning on & off the on board sound to no avail. I have a GeForce 750ti & have done the same. I even watched E-MU Playback & Record in windows sound while trying to play music with 4GB, 8GB, & 16GB ram I can hear the music fine but windows sound set to Wave E-MU DSP in Recording acts like nothing playing.

Surely someone knows how to work around this problem. The E-MU cards are still selling on ebay for $150.


No matter what I cannot get Audacity, Cool Edit 2000, or Wavepad to work. What I was told to try by jmail on another forum was to try Reaper & using the ASIO driver KNOCK WOOD I’m using 16GB of memory. Here’s my setup in case anyone else runs into this. I REALLY wish Audacity could use the ASIO :frowning: Damn copyrights!


Click “Options” “Prefrences” “Device” change “Audio System” to “ASIO” change “ASIO Driver” to “E-MU ASIO”

Under “Enable Inputs” change “First” to (7: Aux 1 L) change “Last” (8: Aux 1 R")
Under “Output Range” change “3: ASIO 31/32” change “Last” “4: ASIO 31/32”

Click “Options” “Prefrences” “MIDI Devices” right click “KeyRig49” click “Enable Input” right click
“E-DSP MIDI Port [EC00]” click “Enable Output”

This will let you record from Computer/Stereo/Microphone & play “Keyrig49”

In that case, I recommend always using 48000 Hz project rate in Audacity.

Are excessive effects being applied by EMU?


It can. But you have to compile Audacity with ASIO support enabled.

So is that working for you?

I think there might be other things you can do for Audacity and other apps to tweak resource management on the computer. Are the recordings bad, or only playback of them (that is, do the recordings play back OK to the built-in sound card)?

If the recordings are bad, why not post a sample here? See How to post an audio sample.


Thank for your reply Gale! I don’t really know how to compile Audacity with ASIO.

The way I listed above is working.

The problem I was having before sounded exactly like this in the link here: (Fast Forward to 1:30) All sounds were correctly heard while playing as Audacity was recording but upon playback of the recording that is what it sounded like. Although 99.9% of the time I couldn’t even get Audacity, Cool Edit 2000 or Wavepad to record sound using MME, Direct Sound, WASAPI. Reaper recorded sound from all sources using WDM, Direct Sound, Waveout, & WASAPI but sounded the same as the link. ASIO was the only thing that fixed it with the above settings.

I will post a sound sample for you using Audacity.

I’m using Crucial CT7348776 16GB of memory with an ASUS M4A77T/USB3, AMD Phenom II X4 955, E-MU1212m, Behringer 1622fx

To reproduce the sound problem I had to record from my stereo using WASAPI (loopback) with my E-MU1212m sound card. This is the only way I could get sound.

A .WAV file recorded fine using WASAPI (loopback)

MME & Direct Sound recorded silence.

Thanks for the sample. So to be clear, does the waveform record as in your attached sample? If you zoom the recording to show about five seconds in the visible screen, do you see a series of spikes with “silence” (low level noise) either side? Or do the waves look correct when zoomed in, and you recorded that file with WASAPI loopback to demonstrate it’s a playback problem?

Does the motherboard sound device have the same issues as the E-MU?

The resources issues that I had in mind you could tweak are listed in this article:

For example, you could look at whether you have reduced your paging file to allow for the larger memory, and likewise check if excessive swapping is actually occurring. At the bottom of that article there are a couple of Deferred Procedure Call testing tools you should try.

If a reduced latency API is going to help, then without compiling Audacity with ASIO support you could try Audacity 2.0.4 from 2.0.4 has support for WDM-KS which can reduce latencies close to ASIO levels.

Be warned that that WDM-KS support could crash or blue screen your computer, hence we have not released WDM-KS-enabled Audacity except for version 2.0.4.

If there was a crash it would probably occur with your built-in sound card - it seems from forums that the EMU’s WDM drivers do support WDM-KS, but that the WDM drivers are not as thoroughly implemented as the ASIO drivers. I’ll leave researching that to you.


Your Welcome :wink:

Yes waveform records as in sample.

I do see series of spikes with “silence”.

Yes I recorded the sample with WASAPI loopback to demo the problem I’m having.

I never tested the Motherboard as I do not have the cable needed to connect to my mixer.

Thank you for the extra info!