Audacity doesn't see new HDD

I’ve added an internal hard drive to my Ubuntu system and partitioned it and formatted it to ext4.

Using the disk management GUI I have configured the partitions to mount on startup and from the desktop I can see them and write files to them.

I installed Audacity which came by default as the snap install.

But when selecting a directory to export, Audacity can only see the default system partitions and the system and folders within them. These are on a SSD, but I don’t want to use those defaults. I want to use my new large HDD.

In preferences: directories>browse the hard drive partitions don’t show, even though they are mounted. I can navigate from there to the mount points via “choose a location” window, click file system icon, but Audacity is not allowed to open the system directories.

I can give overall R/W permission for my music folders on the HDD, but it seems not for the actual HDD partitions. In the disk management GUI there is a setting to “take ownership” and I can click OK and check “recursive mode” but that setting is not maintained and makes no difference.

Can anyone say what I am missing?

The AUP3 format requires an NTFS drive. (Something related to the database format they chose).

I installed Audacity which came by default as the snap install

The snap is not maintained by us and it looks like it’s not maintained by anyone currently - it hasn’t been updated since 3.1.3, we currently are on 3.3.3. Try using the AppImage from audacityteam.org or the flatpak instead, those are more recent.

I strongly suspect that the issue is related to the snap.

That’s not entirely correct; Audacity requires the drive to not be fat32. That’s because fat32 is limited to files no larger than 4GB, and projects tend to easily be larger than that. On Windows, it’s true that NTFS is the main alternative here (though ReFS and exFAT probably work too), on Linux, most file systems should work. Ext4 has a limit of 16TB per file, which is plenty.

Doug I’m not so sure about requiring only NTFS. My last system was entirely ext4. All my music was kept on the linux home folder, which audacity was able to export to directly.
I will try the alternative to the snap install and get back

I’ve uninstalled the snap and downloaded the 3.3.3 appimage but damned if I can get it to install. I’ve tried both right clicking and in properties click to allow executing as program, right click, run as program, nothing
Tried the chmod +x file path, then right click again nothing.
There is supposed to be a desktop setting Action to do when launching a program from the desktop dropdown>launch the file , which I remember seeing somewhere, but now I can’t find it.

I found a solution at itsfoss.com. I needed to install libfuse. Now I can run the appimage.
(That itsfoss guy is amazing, he has fixes for everything and well explained)
But I am not clear about something. I didn’t know what an AppImage was, apparently it contains the whole programme but you can’t make Audacity desktop icons, shortcuts etc. So I have to have the whole program on the desktop. Is that right? Is it not possible to install Audacity the “old” way? Ubuntu Software has version 2.4 as a deb but if you want to update it takes you to the AppImage.
I don’t especially like the look f the AppImage but at least it can see the new HardDrives.

This topic was automatically closed after 30 days. New replies are no longer allowed.