Audacity doesn't recover the last project after crash


I had a problem and I can’t find to run Audacity normally anymore.

Audacity crashed when I added a sound piece from another project (a not saved project) pasting it from the clipboard. It closed and when I tried to open it again Audacity offered me to recover both projects. But it didn’t work.

Audacity opens and show a modal window offering to recover both projects. But Audacity simply doesn’t do anything if a select one, both or none of the lost projects. This pop window doens’t let me choose not to recover or do anything else.

I tried to rename the folder where the original saved project is but it stil offers me to recover it.

I rebooted several times, and tried to open Audacity from another .aup file (older projects), but it just offers me to recover the new ones.

Is it possible to run Audacity avoiding recovering any project? Or the saved version without the last changes?

My Audacity version is 2.0.6 and I’m running Debian Jessie (almost up to date). Thank you.

That window lets you recover unsaved changes for all the projects or discard unsaved changes for all the projects. It doesn’t let you recover unsaved changes for one selected project and discard unsaved changes for other unselected projects (even though it looks like it might).


Unlike saved Audacity projects, recovery of unsaved changes relies on absolute path, so please don’t rename directories if you are ever intending to recover unsaved changes.

Simply press “Discard Projects” in the “Automatic Crash Recovery” dialogue. That will delete the AUTOSAVE files for each project’s unsaved changes. Then CTRL + W in each project window. Then open the AUP files to go back to the state the project was last saved in.

If you choose “Recover Projects” by mistake, just CTRL + W, say “No” to “Save Changes?”, then open the AUP files normally.

When you open the AUP files, you will probably see a warning dialogue about “orphan files” (which are the data for the unsaved changes). You should be able choose the option in that dialogue to delete the orphan files without harming the saved project.

If you really don’t want to see the “Automatic Crash Recovery” dialogue at all, then you will need to delete the AUTOSAVE files for each project’s unsaved changes (or rename their extension to something other than AUTOSAVE). The AUTOSAVE files are in ~/.audacity-data/AutoSave (show hidden folders in your file manager to see that folder). Then as above, just open the AUP files normally.


First of all, thank you!

But maybe I’m not good enough to explain the problem because my native language is not english. I’m not interested in recovering unsaved changes. I’m only interested in running Audacity again. I can’t do anything. No option is available. Audacity does nothing, just shows the modal window. No menu option, no button and no key combination are available. I can’t action any menu option. And no key strikes makes aney change in Audacity behaviour.

I will try to delete the ~/.audacity-data/AutoSave and I will tell you.

Thank you again.

I don’t understand that, unless Audacity is frozen up when it tries to recover. You should be able to use a mouse to click “Discard Projects” here:

If you don’t have a mouse, TAB into the “Discard Projects” button, then hit ENTER or SPACE.

If you delete the AutoSave folder there will be no Automatic Crash Recovery dialogue.


Thank you but the problem was not having any button. And It wasn’t possible to close the window.

But now it’s solved. I’ve deleted the AutoSave file and I can run Audacity normally.

I’ve attached the the only window I got before deleting the AutoSave file.

That’s broken. And “About Audacity” has no Close button.

What desktop environment are you using? Have you turned buttons off in that environment?


Gnome, no customization, just as it’s installed by default. I’m running Debian Jessie. I gave up customising because every update (every day) I loose them, so I prefer not to customize.

But now I have the buttons back again! Audicity is working as usual and I’m glad. I really needed it to edit some audio pieces for my radio program.

Thank you a lot!

How did you get the buttons back?

Once you said that you had not made desktop customisations, I would have suggested as first step that you initialise audacity.cfg.