Audacity does not start

Hello everybody,

I just installed Audacity 2.4.2 on my Macbook pro running with Catalina 10.15.6 and I cannot get it to start.

When I start from dock I just get an popup saying something like “Audacity-Startup Error - An unresolvable error occurred during startup” (translated from German).

When I try to start the application from console I get the same popup again and following notifications inside the console

open /Applications/

/Applications/ ; exit;
Attempting to connect to Audacity failed...retrying
Attempting to connect to Audacity failed...retrying

Tried to reinstall the app already and also deleting the settings-file, both didnt do any change.

Did you get Audacity from here: ?

Can you check that your SHA 256 checksum matches the one on that page?

– Bill

yes, downloaded from there and SHA256 checksum matches.

Try deleting all three of the settings files:

  • audacity.cfg
  • pluginsregistry.cfg
  • pluginsettings.cfg

there is only “audacity.cfg” together with a folder “SessionData”, which is empty - the other two files are not there

What is the exact (and full) location of the audacity.cfg file?

~/Library/Application Support/audacity/audacity.cfg

I presume that you get the same error if you try to launch Audacity with:

open -a audacity

Unfortunately I don’t know much about troubleshooting on macOS. For me, Audacity 2.4.2 just works on Catalina.

Is there anything unusual or non-standard about your Mac?
What audio devices do you have?

Were you previously running an earlier version of Audacity on this machine?

Anything you can think of that might be relevant to the problem?

yes, I tried that one before, but same result.

I was installing Blackhole prior to Audacity, because I wanted to record the sound from a Language-learning program and I suspect it has something to do with my problem. I uninstalled it again, but still the same result.

standard Macbook pro 13" 2020

First time I was trying to use the software. I used it before under linux and had no issue with it.
I guess I will try resetting the macbook to default again and see if the problem is gone…

I don’t suppose that you tried Audacity on the Mac before installing Blackhole?

unfortunately I didnt

I had the same issue, of Audacity not starting on Catalina.
After a lot of commandline launch attempts I checked the crash report, after I force quit the not-starting-Audacity, and found some lines about MIDI…
The audio/MIDI config app also hung.
Eventually I had to remove the MIDI drivers from ~/Library/Audio/MIDI\ Drivers/ and …/…/Library/Audio/MIDI\ Drivers/

under those links I had no content except some empty folders.

Anyway - I reinstalled catalina again and it works fine now, also with Blackhole installed.

I’m having exactly the same issue. Apologies, I’m a complete novice. How do you reinstall Catalina?

Have you updated to Audacity 2.4.2 or are you still using an old version of Audacity?

Hi, I tried re-installing Catalina, but it still doesn’t work. I was using an old version on a previous computer - 2.3.3. After the re-installation the blank audacity.cfg folder that was there before has vanished. I’ve created a new one in text edit and no joy. It still doesn’t work.