Audacity does not record [SOLVED]

I am a long time Audacity user who had a hard drive failure and went to an SSD and Win 10. Now all I get is a flatline - sometimes a faint line response but only at maximum gain. I have no audio problems outside Audacity - Cd’s play, videos play, etc. I have spent hours trying to use FAQ info to solve this problem. Any help would be gratefully received. Here are my specs:

Intel(R) Core i7CPU, 12 GB RAM, 64-bit OS, Audacity 2.1.3-alpha Nov 24 2016
Audacity settings at present are : MME, CD Audio (Realtek HD), 2 (Stereo Recording), Dig. Output(RCA+Optical), Project Rate 44100

Sound settings presently are: Playback: Speakers (RealtekHD Audio) Default ; Dig. Output (RCA +optical) Ready; Realtek Digital Output Ready
Recording: CD Audio (RealtekHD Audio) Default; Microphone default Communications Device (Realtek)
Sound: Windows default
Communications: Do nothing

Excellent listing. Now. What are you doing?
We need a sentence such as: “I want to record my USB turntable.”


I make videos and search the web for suitable music, sounds etc. to use with clips.


Where are the extracts playing that you want to record? Most CD audio inputs don’t actually record from a CD. See Tutorial - How to import CDs.

If the extracts are playing in your web browser through the digital output, you can record using Windows WASAPI loopback: Tutorial - Recording Computer Playback on Windows - Audacity Manual .


Many thanks, I’ll give it a try.


Gale or anyone… So as suggested by Gale I plugged in the WASAPI loopback settings from the website suggested, started up some music from a WMA file and got a response on my recording line, but it was horrendous noise! The music was playing perfectly prior to clicking the Record button. So, any suggestions…

Bob Olafson

Why would you record a file? Is it crippled with Digital Rights Management (DRM) restrictions so that Audacity cannot import it? If you install FFmpeg then you can import unprotected WMA files directly into Audacity.

If you must record the WMA file, in what application exactly is that file playing, and in what audio device do you hear that file? Speakers (RealtekHD Audio)? Digital Output (RCA +optical) ?

With WASAPI loopback you should set the playback device in Audacity to the device on which the sound is playing, and the recording device to the (loopback) input of the device playing the sound.


  1. In Audacity, open Device Toolbar.
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Recording Device) box, choose the (loopback) input for the device you are using for playback. For example, if you are using “Speakers” for listening to playback, choose “Speakers (loopback)” in this step.
  4. In the third (Recording Channels) box, choose mono or stereo.
  5. In the fourth (Playback Device) box, choose the Speakers or Headphones that you are using for listening.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.

Note that if the device playing the audio demands exclusive access to the sound card, WASAPI loopback cannot record from it. In that case, use another device to play the audio.

Or if your computer has a blue Line-In stereo input, separate from the pink microphone input, you can connect a cable from audio out (green) to Line-In and tell Audacity to record from Line-In. Of course, this is a little lossy (because of the Digital → Analogue → Digital conversions ) and you will need an adaptor to double the audio out so you can connect some speakers or headphones to listen.


Thanks for the response Gale. If you look at my last Post you can see that I followed the instructions on the Web site you noted earlier AND which is exactly what you just suggested in the itemized list of your last post. The file I tried to record was chosen only to see if I can actually get Audacity working at all. I know Audacity would previously have recorded that music pre Win10. What I got was a huge noise - which looked like it was recording. As for your further comments, I’m sorry but I really don’t understand what you are suggesting. With all do respect, I’m not computer illiterate but I am pretty frustrated with Audacity just now.


Sorry, Bob, but we couldn’t see that from what you wrote “plugged in the WASAPI loopback settings from the website suggested”. Lots of people say something like that but do something wrong somehow.

But you are now on Windows 10 - different operating system. Is it the same computer that you had before, apart from changing to an SSD? If so, the machine possibly does not support Windows 10 - it matters when it comes to recording. I would recommend going to the web site of the computer manufacturer, look up your exact model, and see if there are Windows 10 audio drivers for that model. If you have 64-bit Windows, get the 64-bit drivers.

Make sure you have not turned on Transport > Software Playthrough by accident. The Tutorial does say (at the top of the page) to turn it off.

I am suggesting making a physical loopback by using a cable. But it will only work properly if you have a separate stereo Line In on the computer meant for high quality stereo signals. If you only have one audio input, it will be either a mic input, or a low quality “compatible” mic and stereo signals input.


Got it! Thanks Gale, Transport was ‘On’. I’m in business.