Audacity does not recognise Blue Yeti mic as recording device


I’m using Audacity 2.3.3 (PPA version) on Ubuntu 18.04. The hardware is Dell XPS 15" and a USB Blue Yeti mic that works perfectly with Skype.

However, Audacity only recognises it as a playback device: ‘Yeti Stereo Microphone: USB Audio (hw:1,0)’. The mic is not available as a recording device option. Only the internal, headphone and headset mics are present, each via default, pulse, sysdefault and HDA Intel PCH. I use the default/only host, ALSA.

Any idea how I could make it work?

Screenshot from 2019-12-27 23-23-35.png

The Yeti is supposed to be able to Plug and Play with generic settings on most computers. However, I have had Stereo/Mono crosses get messed up.

I don’t remember the failure in detail, but I told Audacity to expect a mono microphone and instead, the microphone delivered in stereo. It didn’t just create a minor format error, the microphone actually vanished (electrically).

There is one other item. Plug the Yeti in first, let it settle and then run the software. No, I don’t think that’s it, either, but we shouldn’t ignore any condition or setting.


Hi Koz!

Thanks for the quick reply, much appreciated!

You are correct, as per your reply and per various other sources I’ve consulted before posting, the mic needs to be plugged in before Audacity is started. But that alone didn’t solve my particular situation.

Another thing I read about was going for Transport → Rescan Audio Devices. That didn’t work either.

But, as I was simply going through all of Audacity’s menu options, I’ve (just now) run Help → Diagnostics → Audio Device Info. That did its thing and shown a popup list of devices. After that, my Yeti mic appeared as a recording device and I could finally use it. Not quite sure I follow why and how it happened, but it worked for me.

Many thanks again!


Did you ever find a solution to this issue? I’m having the exact same problem.

Try “Rescan Audio Devices” (

I am using Ubuntu 19.10 Desktop and Audacity 2.3.3 (installed from the Ubuntu software repository).

Audacity only sees the “default” device in both recording and playback. I tried using the Transport menu’s “Rescan Audio Devices” and it did nothing. Therefore, my Blue Yeti is not recognized.

Even though the Yeti does not show up in the Device Toolbar, I can record a track with my mic. But then I get the dreaded “plays back at way too fast of a speed (sounds like a chipmunk)” problem.

Is there a better Linux software for recording with my Blue Yeti that I should be using? (It seems Audacity has had these two problems for a long time.)
Any advice appreciated!

In Ubuntu’s Settings application under Sound, I changed my Input Device to be “Microphone - Yeti Stereo Microphone”. That cleared up the “playback sounds like a chipmunk” problem but the device toolbar still does not see the Yeti microphone as a recording or playback device (even when I use Transport ==> Rescan Audio Devices. It just lists “default” as the only choice for both recording and playback.

So, I guess it is useable but it gives me pause if all of the Yeti’s capabilities and sound patterns will be recognized and useful.

I wish I knew how it worked for user sliute.

Do you use PulseAudio? (It is the default sound server in Ubuntu). With a properly working default Ubuntu installation, you should at least see an option for “Pulse” in addition to “default”.

(I’m installing Ubuntu 19.10 in a VM now - it looks like it will take some time)

I am only seeing the ALSA option. I ran:
pulseaudio --start
from the terminal yet I still only have the ALSA option.

I also had to install the Pulse Audio volume control
sudo install pavucontrol
as it did not come preinstalled with Ubuntu 19.10 Desktop.

However, I still only get ALSA as a choice for Host and “default” sole choice for record and playback devices.

Maybe it is a 19.10 quirk?

OK, I guess my Audacity is working correctly after all. I read here:

ALSA: Audacity’s ALSA support is the default and considered stable. The correct device to use on out-of-the-box ALSA setups is “Default”. This provides software mixing and resampling of multiple streams as found on other operating systems, and is a good alternative to a sound server. This is almost always the right sound device to use, and you can ignore the others. “Default” is the same as “pulse” on systems where PulseAudio is default sound system.

PulseAudio: Audacity’s PulseAudio support generally works well. PulseAudio doesn’t support ALSA’s mixer interface so Audacity’s Mixer Toolbar input slider is disabled under PulseAudio. Audacity can freeze using PulseAudio if playback or recording are started or stopped very rapidly or frequently. Playback can also occasionally be distorted or excessively fast.

So, that is exactly how my system behaves under ALSA and now I see why I only see default as the choice for record and playback. At least the recording and playback works so I guess I will just leave it alone for now.

I’ve finally got Ubuntu 19.10 running, and I see a full set of inputs and outputs as expected, so it’s a mystery why you are only seeing “default”. Nevertheless, as it’s working for you, probably best to leave it alone.

I uninstalled Audacity 2.3.3 from my Ubuntu 19.10 desktop and then installed Audacity 2.3.2-2 from the ubuntu-eoan-universe source. Now I can see all of my inputs including the Yeti for record and playback!

Audacity works great now!

I’d recommend that you report that to Ubuntu.