Audacity does not generate pluginregistry.cfg

When starting audacity 2.12 on one of my ubuntu 16.04 machines, I’m greeted with a “debug report” dialog. examining the log in the generated folder shows that pluginregistry.cfg does not exist. following advice I found elsewhere on this forum, I deleted .audacity-data and reran audacity to regenerate it. the folder was regenerated and a few files and a folder were created inside, but pluginregistry.cfg was not created and the same dialogue appeared creating an identical report folder. I then tried creating an empty pluginregistry.cfg with touch and the created file was deleted when audacity was ran, resulting in the same dialogue and same report. I then tried reinstalling audacity through apt to no effect. I also tried reinstalling the audacity-data package. I then tried using the .deb files directly from the online repositories to no effect again. I made sure to uninstall audacity before each of these attempts

I have another machine with the same ubuntu and audacity versions which functions normally. I was going to transplant the pluginregistry.cfg file from that pc to this one, but found that the working installation does not have a pluginregistry.cfg in its .audacity-data.
audacity-report.tar.gz (10.1 KB)

“2.12” is a typo, It should be 2.1.2. :wink:

Pluginregistry.cfg does not get written until you launch Audacity successfully and open Plug-in Manager.

I see in log.txt

17:50:11: Error: Impossible to get permissions for file '/home/trevor/.audacity-data/pluginregistry.cfg' (error 2: No such file or directory)

If you are launching Audacity from the terminal with the sudo command, or running the terminal as root, don’t.

Also make sure your own user is a member of the “audio” group.

If the problem continues after that and audacity.cfg in the Debug Report still contains no audio devices, then the audio devices on your computer are probably the problem.

aplay -l


arecord -l

(that’s -l as in “lovely”) will show you your playback and recording devices.


I apologize for the very late response. I was expecting an email notification when someone replied.

To address you points in turn: I am running audacity as my own user, not as root (though out of curiosity I tried it as root when you mentioned it and, unsurprisingly, it didn’t help), my user is a member of the audio group, and aplay -l and arecord -l list numerous devices that I have been able to use all of successfully with pulseaudio, jack, and straight alsa (not at the same time, of course). the outputs of the two are attached. I also attached the log generated by running as my user in case it is any different. (9.48 KB)
devices.txt (2.72 KB)

If you subscribe to the topic (see bottom left) then you should get an e-mail, but you may need to check your Spam or Trash folders.


None of your debug reports show any audio devices, so I suspect that is the cause of the problem. Perhaps you could disable all but card 2 and see if that helps. Not all audio devices are compatible with Audacity, which could be relevant if your hardware was really meant for Windows.

Have you tried installing Wine and seen if the Windows release of Audacity 2.1.2 runs?


I have two physical sound devices in my machine. One is built into the motherboard and the other is built into my graphics card (since it has hdmi output). I was able to disable the virtual sound devices (loopback and dummy) but I could not disable the hdmi device despite blacklisting the snd_hda_codec_hdmi module (it still loaded on boot). Audacity still crashed with the report in “audacity-report-new” I then reinstalled audacity and tried again, resulting in the report “audacity-report-new-after-reinstall” running the diff command on these folders showed that they only differed in timestamps and the “address” property in the audacity.xml file

I downloaded the windows version of audacity and ran it in wine. it was able to start and play white noise. I might be able to use this in an emergency, but I would greatly like if I could use the native Linux version since I would like to more easily be able to leverage jack (which I should note was off for the tests) and since some parts of the user interface (such as drop-downs in the settings menus) do not work properly.

You mentioned that some sound cards are incompatible with audacity. may I ask what besides a fully-functional (in my experience) alsa driver is required?
audacity (21.8 KB)

Let’s see how far it’s getting when you try to launch:
Open a terminal window and navigate to the directory where the “audacity” executable is installed, then enter the command:

./audacity &> "valid-path-and-file-name.txt"

Attach the file to your reply.

The output file is completely empty, though if I have the file open in an editor while running the command, I get the file-has-been-changed notification even though it remains blank after reloading. I assume that is just bash grabbing the file so it is ready to feed it output. I tried the command with and without quotes around the file name.

Is there any output on the screen if you echo the output to screen and file?

./audacity 2>&1 | tee file.txt


the command produces no output in either the terminal nor in the file

Fully functional ALSA driver should be the only thing required, assuming that Audacity has been built correctly with all the necessary dependencies.

Does Jack Audio System work on this machine?

I use Jack regularly on this machine and have not encountered any issues.

That does remind me, however, that I use the linux-lowlatency kernal since I use jack the entire time the machine is on (except when trying your suggestions to fix audacity when I turn jack off). Can using the lowlatency kernel interfere with audacity?

Does Audacity launch when Jack is running? (have you tested both with and without Jack running?)

Yes, The tests I mentioned in my first post and most of the ones asked of me were tested both with jack enabled and with jack disabled.

This is very odd. If Jack is running then there ‘must’ be at least one device that Audacity can use (assuming that Audacity has been built with Jack support enabled).

Has Audacity ever worked on this machine?
How did you install Jack?
What repositories do you have enabled in sources.list?

Are other applications using JACK and/or you audio devices when you launch Audacity?


Normally, the only jack clients on the machine are a pulseaudio-jack bridge (part of my preferred jack controller, the Cadence suite),an alsa_out to allow output to the hdmi output in addition to the motherboard soundcard, and sometimes an instance of carla, a plugin host. I tried starting audacity with various combinations of these on and off to no effect


How did you install Jack?

the jackd package from ubuntu universe

What repositories do you have enabled in sources.list?

I have attached a zip archive with my sources.list and my sources.list.d (13.3 KB)

Rather a lot of different repositories there.
Where did your version of Audacity come from?

audacity is installed with the audacity package from ubuntu universe

Unless Gale, or anyone else, has more ideas, I think we’ve covered all of the easy options. We can see that Audacity is crashing early during its start-up process, but I can’t see anything to indicate what is making it crash, and as far as I’m aware it is not a known problem, and is not reproducible on our computers. We also know that the affected computer has a mix of software from many repositories (including “unsupported” repositories). We also know that the hardware set-up is quite complex (having HDMI audio via the graphics card in addition to the sound card), so if the problem is hardware related, we are not going to be able to reproduce the problem.

At this point I think I need to ask: How important is it for you to get Audacity working on this machine?
In order to trouble shoot the issue further, I think we are going to need better debug information, but that will require running a “Debug build”, and Ubuntu Xenial does not appear to have a debug build of Audacity.

The way that I would approach this problem (if it was on my machine) would be to build a debug version of Audacity from the source code. This ‘could’ in itself solve the problem, because Audacity would then be built against the libraries that are installed on the machine (libraries on your machine may be from other repositories, so there ‘could’ be compatibility problems with the libraries that Ubuntu used to build Audacity).

Building Audacity from the source code ‘may’ not be straightforward as you may have incompatible dependent libraries installed (which could be the cause of the problem).
IF Audacity (debug) builds OK, and the problem persists, then we would be able to get a “backtrace”, which may at least give us a clue as to where/when the crash occurs.

Pursuing this further is going to take time and effort. We are happy to try and help, but it’s up to you how much time/effort you think it’s worth investing in this (with no guarantee of success). I understand if you decide it’s not worth the effort :wink:

If you do want to continue, do you have any experience building applications from their source code?
There are step-by-step instructions for Ubuntu 14.04 here:
(Ubuntu 16.04 should be pretty much the same).