Audacity Device setting issues

I’m new to Linux & attempting to convert a quad-core PC to a Linux Mint audio recording PC for my church. I posted this issue on the Linux Mint forum and haven’t really been able to resolve it, except to buy a new audio card to attempt to fix the issue.
I followed the Audacity setup guidance and with the recording device set to ‘default’, ‘pulse’, etc. I get a good bit of noise in the recording (pops and crackles). If I select the audio card (HW:0,0) input, the recording is perfectly clear. I can control the “line in” input level with Pulse volume control BUT, if I open pavucontrol, it appears to steal the audio card from Audacity and I have to reboot the PC to get things working again. The folks helping me on the Linux forum seemed to think that my problem is that I am attaching directly to the hardware instead of through pulse. Any ideas on resolving this issue?
I need the clear audio recording of selecting the audio card hardware device but also need to use pavucontrol.

I’m using Linux Mint xfce, Audacity 2.2.1, distro release.

Why do you need to use pavucontrol?

Granted I’m very new to linux but just attempting to follow all the guidance I’ve found relating to best methods to control sound in Linux, including Audacity forums and documentation. What do I use in the place of pulse audio control/mixer? Do I need anything else besides Audacity? I’ve tried removing pulse audio mixer & seems like i encountered issues in audacity. I’ll try it again. My goal is to make Audacity as “repeatable” upon startup as possible since I have multiple people who operate the sound board and recording PC. One of the main issues I’ve seen is that the “required” audio card device (HW:0,0) input does not always show up for selection in audacity. I need Audacity to always default to the correct device or I will end up with pops and crackles. If pulse audio control doesn’t help ensure this, then what can?

Leave pavucontrol installed - it’s a very useful tool to have, but you only really need to use it with Audacity if you want to record sound that is playing on the computer (rather than recording external sounds).

When I record from my mixer, I generally use a Behringer UCA 202, which has stereo “line level” inputs (my mixing desk does not have USB). I find that this gives me much better sound quality than my computer’s built-in sound card (and they only cost around $25). Nevertheless, you may be able to get acceptable quality from a built-in sound card (depending on the sound card, but most built-in sound cards are not very good).

Whether I use the Behringer, or built-in, I normally use the “hw” option, which completely bypasses PulseAudio. The downside of this is that other audio applications (including pavucontrol) cannot be used at the same time, but that’s not generally a problem if you are only recording / playing with Audacity.

Rather than using PulseAudio, the “hw” options tell Audacity to use the ALSA device directly. Controlling the input / output levels can be done with “ALSA Mixer”, which is a simple mixer for ALSA devices, and is usually installed by default. To launch ALSA Mixer, open a Terminal window and enter:


(nice and easy to remember :wink:)

When using the Behringer UCA 202, there are no level controls for the device, it has fixed gain at “line level”, so controlling the input level is done from the mixer. This is typical for USB audio devices, though many of the more expensive ones have input level controls built into the device,

Thanks for the do’s and don’ts relating to Audacity and Linux!!! Also appreciate the suggestion on the Behringer. My next Amazon purchase will be a USB audio card. Does the Behringer work on Linux?

I use the Behringer UCA 202 on Linux. I know that the UCA 222 also works on Linux (it’s basically the same device with the addition of an optical output, a different color case, and slightly higher price tag).