Audacity crashing on record button

Audacity 2.3.2, running on Mac OS Mojave crashes when I try to record.
If there is no open track at all then it’s okay, but if there are any tracks at all in the project then the record function fails and Audacity crashes - not even the error reporting works (this locks up too). The only was to close Audacity then is a Force Quit.
I actually deinstalled Audacity when I found this error, and tried to re-install, but the error comes back in exactly the same way.

This is making the application largely unusable for any multi-track podcast work, and never happened to me with any previous version, so I’ll have to abandon it if I can’t get a fix within a couple of weeks - shame. The attached screenshot shows what happens when I get the crash pop-up. Any ideas?

Screenshot 2019-06-10 at 14.06.55.jpg

Try clearing the Audacity settings as explained under the heading “Reset Audacity Settings on Mac” on this page in the manual.
– Bill

Thanks Bill - that appears to have worked well. Took me a while to find the library option, but once done I’m sorted.
Cheers, Tony