Audacity Crashing on ALAC export [SOLVED]


I’m using 2.06 (although problem also occured with 2.05) on a Macbook Pro (OSX 10.6).

When using “external program” to export a 16bit 44.1k WAV file as ALAC (m4a) file, using the string from the wiki (ffmpeg -i - -acodec alac “%f”), audacity simply closes without saving anything. On re-opening the program offers to “recover project” indicating that the program actually crashed or closed unexpectedly.

I’m using the latest ffmpeg (the one for 2.06), and when i was on 2.05 i also had the correct ffmpeg installed and it behaved in the same manner, closing without saving or exporting.

So basically at the moment I’m unable to export to apple ALAC with Audacity, which is a bummer.

Anyone else having similar issues or ideas on what might be going on?


The crashes are a known bug on Mac if there is anything wrong with the path or command syntax. However it works fine if you follow .

In other words, you have to find and download an “ffmpeg binary for Mac” (Google it, including the quotes). Then give Audacity the complete path to the “ffmpeg” binary. The (external program) exporter needs that binary but the recommended FFmpeg 2.2.2 installer for Mac does not include it - it only comes with the dylib files that the Libraries Preferences loads.


Worked a treat, thanks Gale!